Bug 4109 - Stop Xsun to probe for my keyboard.
Stop Xsun to probe for my keyboard.
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-19 07:20 EDT by lars.v.enstedt
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-02 04:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lars.v.enstedt 1999-07-19 07:20:10 EDT
I am running a Sun Sparc 5 with RedHat Linux (SPARC) 6.0.
I am using a pc keyboard and a logitech mouse. To be able to
do this I have a converterbox from Sun (Sun part nr:
595-3692-01 or 370-2068-01).
The trouble lies in that the Sparc machine (called sparcy)
detects what keyboard you have installed by asking it. And
the converterbox can be set (dip switches)to answer with
which keyboard it is
(becuse pc keyboards do not have that feture). The
converterbox can only be configured to english, american and
german keyboard.

"So what!" you say...
I am located in sweden and am using a (surprisingly) swedish
keyboard.

Now i have swedish keyboard setting implemented at comman
prompt (aka loadkeymap sunt5-se-latin1). Works perfectly.

But when i start X the german keyboard setting is there
again (i have the converter set for german).

my /etc/X11/X file looks like:
exec ../../usr/X11R6/bin/Xsun -fp unix/:-1 $@

My guess is that the Xsun probes for keyboad and then loads
appropriate keymap which in my case is wrong.

So is there a way of turning of this feature (probe
keyboard) when you start Xsun so it uses the keymap loaded
by loadkeymap at bootup?

If not how do I solve my problem?

I have search the web for quite some time about how Xsun
works but have come up with practically nothing.

People at Sun that my problem can't be fixed becuse they
don't have a converterbox that supports swedish pc keyborad.

I have talked to other conver manufacturers (like black box)
and they say good luck we do not have such converters at
all.

I even talked to Sun regarding hardcode the keyboard type in
it's bios (monitor - ok prompt). But the command keymap
there is totaly undocumented as well as nobody knows why
it's there.

So my thougt was that if they say it's inposible to solve my
problem then I should be able to fix it with Linux. :)
But I only got halfway (with getting it to work at command
prompt) and am now turning to you for help on the second
half (getting it to work within X).

//Lars Enstedt
//lars.v.enstedt@telia.se
//+46 8 713 1419
Comment 1 Jay Turner 1999-07-19 09:03:59 EDT
What does your /etc/X11/XF86Config file look like.  There are lines in
it which identify your keyboard to X, and I think this is where the
problem is coming in.  Take a look at that file and you will see a
section for the keyboard settings.  In this section, you will see
commands that set the type of keyboard being used, the keycodes which
should be used, as well as a ton of other settings.  Make sure these
match with the Swedish keycodes you are trying to use.  Reopen this
bug if this does not resolve your problem.
Comment 2 lars.v.enstedt 1999-07-19 11:32:59 EDT
I plugged in my swedish sun5 keyboard and then run Xconfigurator to
see what the correct setting should be. The Sunkeyboard worked fine.
And the output in /etc/X11/XF86Config where:

# XkbDisable

# XkbRules    "xfree86"
# XkbModel    "sun"
# XkbCompat   "compat/complete"
# XkbTypes    "types/complete"
# XkbKeycodes "sun(type5)"
# XkbGeometry "sun(type5euro)"
  XkbSymbols  "sun/us(sun5)+iso9995-3(basic)+se"

This was a change in the XkbSymbols setting. When the converterbox was
used the XkbSymbols line ended with "...(basic)+de". So I used that
version of XF86Config instead of the old one. But I still got the
german keyboard when starting X. I tried to find some documentation on
how you disable the autodetection of keyboard for Xsun servers that is
mentioned in the XF86Config file. I did not find any relevant
information. Ihave also tried to have the XkbDisable uncommented. I
don't know what it does but it had both conection to keyboard an d the
word disable, so... It did not work. I have also tried with all lines
uncommented like:

  XkbRules    "xfree86"
  XkbModel    "sun"
  XkbCompat   "compat/complete"
  XkbTypes    "types/complete"
  XkbKeycodes "sun(type5)"
  XkbGeometry "sun(type5euro)"
  XkbSymbols  "sun/us(sun5)+iso9995-3(basic)+se"

And both with and without the XkbDisable commented.

So the question remains:
How do I disable the Xsun server autodetect and take the configuration
enterd in the XF86Config file?

//Lars Enstedt
Comment 3 David Miller 1999-08-02 04:25:59 EDT
The XSun servers do not look at the XF86Config etc. keyboard
configuration parameters at all.  The type of keryboard is
determined by asking the kernel for the keyboard type code.
Based upon this code, the XSun server chooses they keyboard
layout.  This behavior cannot be changed without an update to
the XSun server.  Trying to support anything outside of standard
Sun equipment (that is Type5) keyboards, was never intended to
be supported.

So what I am saying is, we don't support this configuration
in 6.0  I will look into the issue of enhancing our keyboard
support for an upcoming release.

Note You need to log in before you can comment on or make changes to this bug.