Bug 41090 - dosemu from dosemu-1.0.1-10.i386.rpm segfaults while starting
Summary: dosemu from dosemu-1.0.1-10.i386.rpm segfaults while starting
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: dosemu   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 12:21 UTC by Victoriano Giralt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 12:21:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Victoriano Giralt 2001-05-17 12:21:39 UTC
Description of Problem:
dosemu from dosemu-1.0.1-10.i386.rpm segfaults while starting
The last lines form strace are:
uname({sys="Linux", node="full.machine.name", ...}) = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++


How Reproducible:
Consistently, every time I call dos or xdos

Steps to Reproduce:
1. simply call dos or xdos from shell prompt
2. 
3. 

Actual Results:
The thing segfaults and dumps core

Expected Results:
A dos (C:\>) prompt :-)

Additional Information:
Machine is AMD K6-2 3D 500 MHz 128 MB RAM running RH 7.0

Comment 1 Bernhard Rosenkraenzer 2001-05-17 12:23:38 UTC
Works for me... Make sure you have a valid DOS image installed (e.g. 
dosemu-freedos).

You may also want to update to the dosemu packages from Powertools 7.1 or 
Rawhide, they fix a number of other problems.



Note You need to log in before you can comment on or make changes to this bug.