Bug 41094 - The installer hangs and loops when not able to read a package RPM from the CD-ROM
The installer hangs and loops when not able to read a package RPM from the CD...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 08:47 EDT by Fredrik Viklund
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 08:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fredrik Viklund 2001-05-17 08:47:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.37 i686)

Description of problem:
While installing packages, the installer could not read one package RPM. It
stops and complains that it can't open the file and the dialog box has only
an OK-button. There is no way of correcting the problem (exchanging the CD
or skipping the package). At least no obvious way or anything described in
the installation guide.	The only way of getting out is to kill the
installation with CTRL-ALT-DEL or from the other consoles.

How reproducible:
Always

Steps to Reproduce:
1. Select a CD-ROM made from ISO-images and a CD-reader that doesn't work
perfectly together.
2. Select a package that the installer can't read the proper file for, from
the CD
3. Wait until the installer tries to install the RPM.
	

Actual Results:  
Installation terminated prematurely with messed up
filesystems and an unbootable system. Solution is (hopefully, because I'm
doing it right now) to transfer the ISO-images to the HD and doing a HD
install.

Expected Results:  
The dialog box should present the problem and ask:
1. Try the same file again?
2. Try another location (eject the CD and try another one, or HD)?
3. Skip this package and continue?

Additional info:
Comment 1 Brent Fox 2001-05-17 11:54:17 EDT
Skipping the package could be a potentially very bad idea.  We don't provide
that option because we don't know what other packages may require that one.  If
the package in question was glibc or the kernel, the system would be unbootable.
 I would recommend redownloading the ISOs and trying again.

Note You need to log in before you can comment on or make changes to this bug.