Bug 41104 - libpcre.so not found at startup
libpcre.so not found at startup
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: grep (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 10:53 EDT by Enrico Scholz
Modified: 2012-02-28 08:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 10:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-05-17 10:53:56 EDT
[propably a pcre-problem, but this component does not exist in bugzilla]

Description of Problem:

When booting the system I get the message that the shared library
libpcre.so could not be found.

libpcre.so* is located in /usr/lib which is not mounted in early
init-stages yet.


How Reproducible:

everytime

Steps to Reproduce:
1. install current  grep + pcre
2. reboot


Actual Results:

"grep: shared library libpcre.so.0 not found"
between init-start and mounting local filesystems


Additional Information:
	
# rpm -q pcre grep initscripts
pcre-3.4-1
grep-2.5e-2
initscripts-5.86-1

# mount
...
/dev/hda5 on /usr type ext2 (rw)
Comment 1 Bernhard Rosenkraenzer 2001-05-17 11:30:27 EDT
Fixed in pcre 3.4-2.
Didn't notice because / and /usr live on the same partition on my workstation.

Lack of pcre component in bugzilla filed as bug #41107.
Comment 2 Bill Crawford 2001-05-17 12:10:53 EDT
Any chance of putting the update up for download?
Comment 3 Petr Pisar 2012-02-28 08:41:17 EST
The library has been put back into %__libdir as part of usr-move in F18.

Note You need to log in before you can comment on or make changes to this bug.