Bug 411061 - 3D support regression, Radeon Xpress 1100 IGP [NEEDINFO]
3D support regression, Radeon Xpress 1100 IGP
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 15:51 EST by Zoltan Boszormenyi
Modified: 2009-01-09 02:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:30:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
jdeguara: needinfo? (airlied)


Attachments (Terms of Use)

  None (edit)
Description Zoltan Boszormenyi 2007-12-04 15:51:58 EST
Description of problem:

With Fedora Core 7 and updated Mesa and xorg-x11-drv-ati driver,
my notebook (Acer Aspire 3100) with Radeon Xpress 1100 IGP produced
3D accelerated DRI. With a newly installed Fedora 8 it doesn't.
For my previous adventures with my notebook, see:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=251642

My notebook hasn't changed since that report, however with Fedora 8,
lspci identifies the integrated graphics differently:

# lspci -s 01:05.0
01:05.0 VGA compatible controller: ATI Technologies Inc RS485 [Radeon Xpress
1100 IGP]

lspci in Fedora Core 7 reported it with this namne:

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M] 

Xorg 1.3 in Fedora 8 reports this below about the chip but unlike
my previous Fedora Core 7 setup, it doesn't try to load the radeon
kernel module or r300_dri.

(--) Chipset ATI Radeon XPRESS 200M 5975 (PCIE) found

The radeon kernel module is loadable manually but it doesn't help.
These two lines are in dmesg after "modprobe radeon":

[drm] Initialized drm 1.1.0 20060810
[drm] Initialized radeon 1.28.0 20060524 on minor 0

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.3.0.0-33.fc8
xorg-x11-drv-ati-6.7.196-1.fc8
mesa-libGL-7.0.1-7.fc8
mesa-libGL-7.0.1-7.fc8
kernel-2.6.23.8-63.fc8

How reproducible:

Always.

Steps to Reproduce:
1. Install Fedora 8 x86_64 on an Acer Aspire 31xx with Xpress 1100 IGP
2. Run glxinfo
3.
  
Actual results:

No 3D acceleration, e.g. glxinfo says:
Direct rendering: No

Expected results:

Working 3D acceleration, since with the components mentioned in BZ 251642
3D acceleration worked on Fedora Core 7.

Additional info:

I saved the original xorg.conf from Fedora Core 7 before I upgraded,
I can append it to the report however it doesn't have any fancy setting
to load r300_dri.
Comment 1 Dave Airlie 2007-12-04 15:56:19 EST
can you add Option "DRI" "true" 

to xorg.conf device section and try again?

we can't get xpress support consistenly working, i.e. it works for you but not
for others...
Comment 2 Zoltan Boszormenyi 2007-12-05 01:47:57 EST
Thank you very much, adding the option worked, I get accelerated 3D now.
Just as with Fedora Core 7, I disabled AIGLX and Compositing just to be
on the safe side as they (and e.g. Compiz) didn't work. I also added
Option "GARTSize" "64" so e.g. ppracer doesn't complain about not enough GART.
Thanks again.
Comment 4 Bug Zapper 2008-11-26 03:50:28 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Joachim Deguara 2008-12-10 23:59:19 EST
This looks like it should be closed
Comment 6 Bug Zapper 2009-01-09 02:30:19 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.