Bug 411071 - 6:3.5.8-9.fc8 arts crashes and produces infinite backtrace windows.
6:3.5.8-9.fc8 arts crashes and produces infinite backtrace windows.
Status: CLOSED DUPLICATE of bug 380031
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 16:07 EST by Orion Poplawski
Modified: 2007-12-06 06:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 12:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-12-04 16:07:23 EST
Description of problem:

After installing 6:3.5.8-9.fc8 from updates-testing, artsd crashes and I keep
getting more and more crashdump windows as it in attempted to be restarted.  So,
two problems: arts is crashing, kde keeps trying infinitely.

#6  0x0052df91 in abort () from /lib/libc.so.6
#7  0x0052593e in __assert_fail () from /lib/libc.so.6
#8  0x00125c8c in pulse_stop (io=0x8c2f430) at pcm_pulse.c:115
#9  0x076b3467 in snd_pcm_ioplug_drop (pcm=0x8c318e8) at pcm_ioplug.c:447
#10 0x0766d1d2 in snd_pcm_drop (pcm=0x8c318e8) at pcm.c:1068
#11 0x07674575 in snd_pcm_close (pcm=0x8c318e8) at pcm.c:696
#12 0x04f6d559 in Arts::AudioIOALSA::open (this=0x8c1de48)
    at audioioalsa9.cc:193
#13 0x04f6cc29 in Arts::AudioSubSystem::open (this=0x8c1a330)
    at audiosubsys.cc:372
#14 0x04f6cdf5 in Arts::AudioSubSystem::check (this=0x8c1a330)
    at audiosubsys.cc:352
#15 0x0805f5a5 in main (argc=17, argv=) at artsd.cc:295
Comment 1 Rex Dieter 2007-12-04 16:24:41 EST
wierd, are you using pulseaudio?  (ie, is kde-settings-pulseaudio installed?)
Comment 2 Orion Poplawski 2007-12-04 16:26:18 EST
[root@cynosure ~]# rpm -q kde-settings-pulseaudio
kde-settings-pulseaudio-3.5-35.fc8
[root@cynosure ~]# ps -fe | grep -Fi pulse
orion     2647     1  0 14:15 ?        00:00:00 /usr/bin/pulseaudio -D
Comment 3 Rex Dieter 2007-12-04 16:31:46 EST
Is the error repeatable, when you restart your session?
Comment 4 Orion Poplawski 2007-12-04 16:46:08 EST
(In reply to comment #3)
> Is the error repeatable, when you restart your session?

Yup.  And if I run arts by hand:

$ /usr/bin/artsd -F 10 -S 4096 -a alsa -d -s 60 -m artsmessage -c drkonqi -l 3 -f
*** PULSEAUDIO: Unable to create stream.
artsd: pcm_pulse.c:115: pulse_stop: Assertion `pcm->stream' failed.

Hmm, maybe this is an X/pulseaudio issue:

[root@cynosure ~]# ls -l /dev/dsp
crw-rw---- 1 root root 14, 3 2007-12-04 14:14 /dev/dsp

Dec  4 14:15:41 cynosure pulseaudio[2647]: module-alsa-sink.c: Error opening PCM
device hw:0: No such device
Dec  4 14:15:41 cynosure pulseaudio[2647]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_2485_alsa_playback_0"): initialization failed.
Dec  4 14:15:41 cynosure pulseaudio[2647]: module-alsa-source.c: Error opening
PCM device hw:0: No such device
Dec  4 14:15:41 cynosure pulseaudio[2647]: module.c: Failed to load  module
"module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_8086_2485_alsa_capture_0"): initialization failed.
Dec  4 14:16:02 cynosure pulseaudio[2647]: module-x11-xsmp.c: X11 session
manager not running.
Dec  4 14:16:02 cynosure pulseaudio[2647]: module.c: Failed to load  module
"module-x11-xsmp" (argument: ""): initialization failed.

I also got some X updates in the same batch:

Dec 04 10:51:27 Updated: xorg-x11-server-Xorg - 1.3.0.0-36.fc8.i386
Dec 04 10:51:57 Updated: xorg-x11-drv-ati - 6.7.196-2.fc8.i386
Dec 04 10:52:07 Updated: xorg-x11-server-utils - 7.3-2.fc8.i386

Still the kde issue with spawning infinite artsd processes though (probably not
anything new there though).
Comment 5 Rex Dieter 2007-12-04 16:59:40 EST
Yes, it's definitely audio driver/pulseaudio misbahaving here.

IN the meantime, you could try disabling it,
rpm -e kde-settings-pulseaudio alsa-plugins-pulseaudio

which should solve the immediate problem of arts crashing.
Comment 6 Sammy 2007-12-04 17:37:42 EST
I don't think it is because since this update (or perhaps another recent package)
I am getting ownership problem with all the sound /dev entries. The entries
/dev/dsp, /dev/mixer, /dev/audio, and pcm's in /dev/snd are all owned by root
and therefor not accessible thus crashing arts (this is without pulseaudio).
Any ideas what is causing this?
Thanks
Comment 7 Sammy 2007-12-04 17:50:45 EST
What version of kernel are you using?
Comment 8 Orion Poplawski 2007-12-04 17:57:49 EST
I'm using 2.6.23.8-63.fc8.  Does /dev/dsp need to be readable by the user? 
/usr/bin/pulseaudio is setuid root and chmod 666 /dev/dsp* didn't change anything.  

pulseaudio --log-level=debug output:

I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2486_alsa_playback_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2486_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2485_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0
sink_name=alsa_output.pci_8086_2485_alsa_playback_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_2485_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2485_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0
source_name=alsa_input.pci_8086_2485_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_8086_2485_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2485_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2486_alsa_control__1
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_2485_alsa_control__1
Comment 9 Orion Poplawski 2007-12-04 18:00:47 EST
Well, running pulseaudio as root seems to startup fine, so I guess it is
permissions.
Comment 10 Sammy 2007-12-04 18:06:58 EST
Yes, it is not the ownership. I just did chmod 0666 for the above devices and
it is working fine.
Comment 11 Orion Poplawski 2007-12-04 18:40:58 EST
I think this is the cause of the permission/ownership issue:

Dec  4 13:29:11 cynosure kernel: hal-acl-tool[2328]: segfault at 74746166 eip
0056cc90 esp bfb60784 error 4
Dec  4 13:29:11 cynosure kernel: hal-acl-tool[2330]: segfault at 74746166 eip
0056cc90 esp bffd4e34 error 4
Dec  4 13:29:14 cynosure pulseaudio[2448]: module-alsa-sink.c: Error opening PCM
device hw:0: No such device
Comment 12 Sammy 2007-12-04 19:39:03 EST
I am not sure about these since I get them on my ThinkPad T42 but not on
my DELL Precison 390 with the same kernel etc. I will report this to kernel
separately.

However, the last few kernal updates contained ALSA updates:

* Fri Nov 30 2007 Chuck Ebbert <cebbert@redhat.com>
- ALSA: fix missing controls on some drivers (#370821)
- ACPI: send initial button state on startup (#275651)

since udev and alsa packages have not changed kernel could be the culprit.
Comment 13 Sammy 2007-12-04 19:56:39 EST
I checked an F7 system and all these devices had user:root ownership
but 0600 permission. After starting KDE these devices where transferred
to the owner. This is no longer happening. Any ideas?
Comment 14 Rex Dieter 2007-12-04 23:38:42 EST
After doing a bunch of tests, I'm fairly certain this has nothing to do with the
kdebase update.  I reverted to stock f8's kdebase, and the problem remained.  I
log into gnome, no audio there either.  Running system-config-soundcard works. 
Logging in as root, audio works.  wtf?
Comment 15 Sammy 2007-12-05 09:14:41 EST
I did that too, as well as downgrading some packages that were in the updates
recently to no avail. I am puzzled. The only way I could somewhat get around
it was to add MODE="0666" to the /etc/udev/rules.d/90-alsa.rules file.

By the way, one package that was updated that I did not downgrade yet was
the xorg-x11-server. Could this be doing something? Changelog does not seem
to indicate anything.
Comment 16 Sammy 2007-12-05 11:13:42 EST
tested that and made no difference
Comment 17 David Zeuthen 2007-12-05 11:59:41 EST
There's a problem with hal-acl-tool sometimes crashing; haven't tracked it down
(it happens very rarely) yet. The quick fix is to 'rm -f /var/lib/hal/acl-list',
'service restart haldaemon'.. and pray :-). 

I plan on fixing this next week and will issue a F8 update. Sorry for this.
Comment 18 Orion Poplawski 2007-12-05 12:23:44 EST
Okay, so bug #380031 is the cause of the permission/ownership issue.  The kde
issue is the infinite number of artsd crash dumps.  How can that be handled?
Comment 19 Rex Dieter 2007-12-05 12:49:24 EST
Re: comment #17
Thanks David!  That did the trick (for me).  yay, no more hair pulling.

Re: comment #18
when pulseaudio doesn't accept arts input (for whatever reason), arts crashes. 
Since arts is essentially unmaintained (upstream), I don't see this changing
(here in fedora anyway).

marking as dup of bug #380031

*** This bug has been marked as a duplicate of 380031 ***
Comment 20 Ivana Varekova 2007-12-06 06:13:17 EST
Fixed in pilot-link-0.12.2-10.

Note You need to log in before you can comment on or make changes to this bug.