Bug 411091 - yum dependency resolution problem with kernel packages
yum dependency resolution problem with kernel packages
Status: CLOSED DUPLICATE of bug 330711
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 16:14 EST by Jean-Philippe Dionne
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 16:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Philippe Dionne 2007-12-04 16:14:57 EST
Description of problem:

As you can see on the following log:

# sudo yum update kernel kmod-nvidia-96xx
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: kernel-x86_64 = 2.6.23.1-49.fc8 for package:
kmod-nvidia-96xx-2.6.23.1-49.fc8
---> Package kmod-nvidia-96xx.x86_64 0:96.43.01-18.lvn8 set to be updated
--> Processing Dependency: kmod-nvidia-96xx-2.6.23.8-63.fc8 for package:
kmod-nvidia-96xx
---> Package kernel.x86_64 0:2.6.23.8-63.fc8 set to be updated
--> Running transaction check
--> Processing Dependency: kernel-x86_64 = 2.6.23.1-49.fc8 for package:
kmod-nvidia-96xx-2.6.23.1-49.fc8
---> Package kmod-nvidia-96xx-2.6.23.8-63.fc8.x86_64 0:96.43.01-18.lvn8 set to
be updated
--> Finished Dependency Resolution
--> Running transaction check
---> Package kmod-nvidia-96xx.x86_64 0:96.43.01-18.lvn8 set to be updated
---> Package kernel.x86_64 0:2.6.23.8-63.fc8 set to be installed
---> Package kmod-nvidia-96xx-2.6.23.8-63.fc8.x86_64 0:96.43.01-18.lvn8 set to
be updated
--> Processing Dependency: kernel-x86_64 = 2.6.23.1-49.fc8 for package:
kmod-nvidia-96xx-2.6.23.1-49.fc8
---> Package kernel.x86_64 0:2.6.23.1-42.fc8 set to be erased
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-x86_64 = 2.6.23.1-49.fc8 is needed by package
kmod-nvidia-96xx-2.6.23.1-49.fc8

On the system there are two kernels installed with the same version but
different rpm release number:
kernel-devel-2.6.23.1-49.fc8
kernel-devel-2.6.23.1-42.fc8

Removing kernel-devel-2.6.23.1-42.fc8 should not break the dependency with
kmod-nvidia.

Manual update with 'rpm' works fine.

Version-Release number of selected component (if applicable): yum-3.2.7-1.fc8
Comment 1 Seth Vidal 2007-12-04 16:29:40 EST

*** This bug has been marked as a duplicate of 330711 ***

Note You need to log in before you can comment on or make changes to this bug.