Bug 411141 - caching-nameserver 9.4.2-1 doesn't have new IP address for L.ROOT-SERVERS.NET
caching-nameserver 9.4.2-1 doesn't have new IP address for L.ROOT-SERVERS.NET
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: caching-nameserver (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 16:54 EST by Richard Fearn
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9.4.2-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 10:27:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Fearn 2007-12-04 16:54:17 EST
Description of problem:

caching-nameserver 9.4.2-1 supplies an out-of-date root name servers file with
the old IP address for L.ROOT-SERVERS.NET.

The update notification for bind-9.4.2-1.fc7 is here:

 
https://www.redhat.com/archives/fedora-package-announce/2007-December/msg00033.html

It says that the IP address was changed in 9.4.2-0.4.1.rc1 ("new
L.ROOT-SERVERS.NET address").

The new 9.4.2-1 package can be downloaded from here:

 
http://download.fedora.redhat.com/pub/fedora/linux/updates/7/i386/caching-nameserver-9.4.2-1.fc7.i386.rpm

It has the old /var/named/named.ca file, containing the wrong IP address.

Version-Release number of selected component (if applicable):

caching-nameserver-9.4.2-1.fc7

How reproducible:

Always - /var/named/named.ca is wrong

Steps to Reproduce:
1. update to caching-nameserver-9.4.2-1.fc7
  
Actual results:

IP address for L.ROOT-SERVERS.NET in /var/named/named.ca is 198.32.64.12

Expected results:

IP address should be 199.7.83.42, as per:

  http://marc.info/?l=bind-announce&m=119404092426633&w=2

Additional info:

BIND has built-in root hints, so a separate root hints file (like
/var/named/named.ca) isn't strictly required. However, the caching-nameserver
example configuration (/etc/named.caching-nameserver.conf) includes the root
hints file, and the sample named.conf file supplied with bind also says it
should be included, so it would be good if the Fedora-supplied hints file was
up-to-date. With the wrong IP address, "missing from hints" and "extra record in
hints" messages are logged to /var/log/messages.
Comment 1 Adam Tkac 2007-12-05 07:11:31 EST
Thanks for your report. I'm not sure why I forgot update named.ca file because
that commit should update it :( Now it is really commited but update will wait
to more serious issue.

Adam
Comment 2 Fedora Update System 2007-12-20 15:14:21 EST
bind-9.4.2-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.