Bug 411151 - PulseAudio should not be the default ALSA device unless it is running.
PulseAudio should not be the default ALSA device unless it is running.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 16:54 EST by Will Woods
Modified: 2008-09-09 18:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 18:39:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2007-12-04 16:54:40 EST
/etc/alsa/pulse-default.conf (from alsa-plugins-pulseaudio) sets pulse to be the
default ALSA device. This results in users being unable to play sounds unless
they start up pulseaudio. GNOME and KDE do this automatically, so it happens to
work in most cases, but it breaks sound for any other use cases.

Either pulseaudio should be started as a system service, or the ALSA default
should not be changed unless pulseaudio is running.
Comment 1 Will Woods 2007-12-04 16:56:15 EST
Also see the discussion in bug 388971.
Comment 2 Will Woods 2007-12-04 16:58:33 EST
*** Bug 388971 has been marked as a duplicate of this bug. ***
Comment 3 Linus Walleij 2007-12-16 14:27:43 EST
Had this problem: I could not run any but a few sound apps when I
installed F8. Turns out it was because PA was not running, so I
was running it in the commandline for a while not knowing where
it should actually be started.

I had an old /home-dir and ESD was diabled. No warning about this,
no clue that not launching ESD would affect PA. (I think a lot of
people will have something like an old /home on a network share,
with ESD disabled ESPECIALLY RHEL users so this is a real blocker 
when RHEL forks from Fedora.)

Then it turns out that ESD == PA (atleast for GNOME users). So now 
I solved this. But not having audio until realizing this was a bit
painful.

See also bug 425501.

(BUT: Lennart, it is worth the effort and PA is super cool, so 
don't loose the spirit because of all these roadbumps!)
Comment 4 Lennart Poettering 2008-05-02 10:38:12 EDT
I don't think it is right to use tha PA plugin for ALSA only when PA is running.
This hides bugs (and also breaks autospawning for those who use it).
Comment 5 Bug Zapper 2008-05-14 00:05:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Lennart Poettering 2008-09-09 18:39:16 EDT
PA in rawhide now enables auto-spawning by default. This bug report is hence obsolete.

Note You need to log in before you can comment on or make changes to this bug.