Bug 41117 - Install fails on Compaq Proliant PL1600R when attempting software-based RAID1
Install fails on Compaq Proliant PL1600R when attempting software-based RAID1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 13:07 EDT by E. Stuart Hicks
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 00:07:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E. Stuart Hicks 2001-05-17 13:07:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 4.0)

Description of problem:
Installer crashes at the point where it tries to format the drives when I 
have a RAID1 disk pair as one of them.

How reproducible:
Always

Steps to Reproduce:
1. Attempt to make one of the mount points a RAIDed drive
2. Continue with the install program until it is time to format the drives.
3. Kick something expensive
	

Actual Results:  The install program crashed with an error message and 
rebooted the computer

Expected Results:  It should have formatted the drives and continued with 
the install

Additional info:

Compaq Proliant PL1600R
400Mhz P2 processor
832M of RAM
NCR53C8xx-based SCSI Controllers


Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1469, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 549, in 
makeFilesystems
    self.createRaidTab("/tmp/raidtab", "/tmp", createDevices = 1)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 462, in 
createRaidTab
    isys.makeDevInode(device, devPrefix + '/' + device)
  File "/usr/lib/anaconda/isys.py", line 195, in makeDevInode
    return _isys.mkdevinode(name, fn)
SystemError: (0, 'Error')

Local variables in innermost frame:
fn: /tmp/raid0p1
name: raid0p1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2001-05-17 13:43:02 EDT
Weird.  We have not seen this in our internal testing.  I'll take a look.
Comment 2 Brent Fox 2001-05-21 15:32:24 EDT
Have you tried Red Hat Linux 7.1?  I'm curious to know if you could duplicate
the behavior with it.

How big are the partitions that you made?  Also, do you see any error messages
on VC3 or VC4?
Comment 3 E. Stuart Hicks 2001-05-21 16:53:56 EDT
I don't have 7.1 to test, and haven't gotten around to downloading it yet.  I 
just knocked out the Linux RAID partitions and put a normal one on one of them 
for now.  The other one is just sitting there being ignored.  That will have to 
change once the server goes live, but that project got put on hold pending 
more "critical" matters.  ("Drop everything!!  We broke something and the 
future of the company depends on you fixing it now!"  *sigh* Mortals...)

They are identical 4gig drives and I made the entire things one partition.  (It 
was only meant to serve as /var/lib/pgsql/data/base.)  Unfortunately, I don't 
remember what was on the other VC's.  I assumed that the Annaconda dump would 
have grabbed everything I'd need.
Comment 4 Brent Fox 2001-06-12 23:41:41 EDT
Ok.  Well, please reopen this bug if the problem reappears in 7.1
Comment 5 Need Real Name 2001-10-19 12:45:37 EDT
I have the exact same problem as stated above, with Redhat 7.1

Using the near exact same hardware, on a Prolaint 1600R, with
Dual 450Mhz P2 processors
390M of RAM
NCR53C8xx-based SCSI Controllers

The installer kicks back the error similar to "a serious error has occured 
attempting to format /.  Press any key to reboot".

I tried several raid configurations:  Two 9.1 gig drives partitioned several 
ways.  If I define them as non-raid, those partitions format fine, but the 
installer "errors-out" as soon as it tries to format any raid partition.  
Thinking that it might be something to do with the drives, I pulled the two 9.1 
gigs and tried the procedure on three 2.1 gigs -- same thing.  It does not seem 
to matter if I try raid 0 or 5, the installer cannot format.

Any help or comments would be greatly appreciated.

sincerely yours,
Hari Boukis

Comment 6 E. Stuart Hicks 2001-10-19 13:36:57 EDT
I also had the same problem with 7.1 and never did get it working.  (I don't 
work for that place anymore, though, so I personally have no real interest in 
it anymore.)
Comment 7 Brent Fox 2001-10-23 00:07:12 EDT
jm3, when the crash occurs, can you press <Ctrl><Alt><F2> and type 'fdisk -l'? 
Please attach the results of that here.
Comment 8 Brent Fox 2001-11-02 10:09:11 EST
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.