Bug 41119 - rdate uses tcp/ip instead of udp/ip and does not close properly
rdate uses tcp/ip instead of udp/ip and does not close properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rdate (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 14:25 EDT by Judah Levine
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 14:25:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Judah Levine 2001-05-17 14:25:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (X11; I; OSF1 V4.0 alpha)

Description of problem:
Many Linux users use the RDATE utility to synchronize their systems to our
time servers. The current version of the RDATE utility contacts our servers
using tcp/ip to port 37. Although this is a supported method, it is very
expensive in terms of network resources since the reply from our system
will always be only 4 octets long. A better strategy would be to use the
udp/ip version of the same service. This provides exactly the same format
of response but it does not require the overhead associated with building
the connection and shutting it down. This would be a significant savings of
resources for a reply that is only 4 octets long.
Finally, for those users who want to use the tcp/ip version for some
reason, it would help if the client program actively closed the connection
after the reply from our servers has been received. Many clients simply
exit, leaving the connection in a "zombie" state. Our servers typically
have hundreds of tcp/ip connections in this "zombie" state. These
connections will eventually be closed by a time-out, but servicing them
until that happens takes resources that are not available for servicing
other requests.


How reproducible:
Always

Steps to Reproduce:
1.run rdate
2.
3.
	

Actual Results:  Program runs okay, but leaves a "zombie" process on the
server. Resources to set up and close down the connection are appreciable
relative to the size of the response, which is only 4 octets.

Additional info:
Comment 1 Phil Knirsch 2001-05-23 08:42:04 EDT
OK, this is more of a RFE than a bug report, resp. it contains both a bug and a RFE.

I've added the UDP protocol support to the newest version as well as fixed the
missing close() call after the message receive as specified by RFC 868.

It should appear sometime in the next weeks on Rawhide for 7.1

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.