Bug 41121 - graphical up2date-config barfs when run as root
graphical up2date-config barfs when run as root
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: David M. Cook
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 14:52 EDT by Clark Williams
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-24 15:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2001-05-17 14:52:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
up2date-config cannot attach to X server when run as root and drops into a
command line config tool

How reproducible:
Always

Steps to Reproduce:
1. su -
2. up2date-config
3.
	

Actual Results:  [root@underdog williams]# up2date-config          
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
0.  storageDir         /var/spool/up2date                      
1.  headerCacheSize    40                                      
2.  httpProxy                                                  
3.  debug              No                                      
4.  useGPG             Yes                                     
5.  retrieveOnly       No                                      
6.  enableProxy        No                                      
7.  keepAfterInstall   No                                      
8.  proxyPassword                                              
9.  proxyUser                                                  
10. headerFetchCount   10                                      
11. versionOverride                                            
12. enableProxyAuth    No                                      
13. noSSLServerURL     http://www.rhns.redhat.com/XMLRPC       
14. noReplaceConfig    Yes                                     
15. noBootLoader       No                                      
16. systemIdPath       /etc/sysconfig/rhn/systemid             
17. serverURL          https://www.rhns.redhat.com/XMLRPC      
18. pkgSkipList        []                                      
19. adminAddress       ['root@localhost']                      
20. forceInstall       No                                      
21. fileSkipList       []                                      
22. retrieveSource     No                                      


Enter number of item to edit <return to exit, q to quit without saving>: 


Expected Results:  The graphical client should have popped up, without
prompting for the root user password.

Additional info:
Comment 1 David M. Cook 2001-05-24 15:16:31 EDT
This looks like an xhosts problem, not an up2date problem.  Can you run other X
clients.  Also, perhaps there is a problem connecting to localhost.  Could you
paste in your /etc/hosts file?
Comment 2 Clark Williams 2001-05-24 15:34:21 EDT
Looks like this only happens on  my laptop, so it must be an X configuration
issue.  

Further exploration shows that doesn't occur when I use 'su -', it's only when I
do a 'sudo -s'. My /etc/hosts file contents:

127.0.0.1	localhost.localdomain	localhost
192.168.0.1	horatius
192.168.0.13	penguin

If you can't duplicate it, then I say we close it out, since I have a
workaround.


Note You need to log in before you can comment on or make changes to this bug.