Bug 411241 - USB drive doesn't work
USB drive doesn't work
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 18:03 EST by starlight
Modified: 2008-01-14 20:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 20:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description starlight 2007-12-04 18:03:53 EST
Description of problem:

This broke sometime since RHEL 4U1, or possibly
due to a change of mainboard to Tyan S2866.

Upon inserting USB connection 'dmesg' shows

usb 1-1: new high speed USB device using address 2
usb 1-1: control timeout on ep0in
usb 1-1: device not accepting address 2, error -71

And drive fails to insert.  Googled the above and
found that running

rmmod ehci_hcd

first fixes the problem.

Version-Release number of selected component (if applicable):

2.6.9-55.0.12.ELsmp
Comment 1 starlight 2007-12-04 19:48:59 EST
Forget about the strange 'rmmod' workaround, the USB disk 
drivers do not work anymore.  Tried copying a bunch of big files 
to the disk.  Data write rate per 'iostat' was a paltry 1MB/sec 
until 1.5GB of data had been copied.  Then it screeched to a 
dead stop.  'iostat' said that 0 kb/s were being transferred at 
9 tps.  This went on for 30 minutes.  A 'sync' command just 
hung. Had to unplug the USB cable to get it out of the bizarre 
state.

This definitely used to work!

Gave up on RHEL and plugged the drive into a Windows 2003 R2-SP2 
X64 server.  Formatted the drive as NTFS and the copy is now 
humming along nicely at 16.5MB/sec.

RHEL is a commercial grade OS?  Not in my book.  This is an 
amateur regression if ever there was one.  Also just finished
wrestling with 'st' tape driver regressions, bug 410231 and
bug 411131.  Might be time to try out SLES.  I know a couple
of companies that have made the switch.
Comment 2 Pete Zaitcev 2008-01-14 20:04:14 EST
Looks like solution was found, closing.
Comment 3 starlight 2008-01-14 20:49:42 EST
Not a Red Hat solution however.

Note You need to log in before you can comment on or make changes to this bug.