Bug 411451 - No Access Points Visible After Resume With iwl3945
No Access Points Visible After Resume With iwl3945
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-04 22:03 EST by Devan Goodwin
Modified: 2008-04-10 17:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-10 17:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2007-12-04 22:03:53 EST
After resume, no access points appear in NetworkManager drop down.

(root@hobbes)[~] # rpm -qa | grep NetworkManager           

Some relevant log entries:

Dec  4 22:38:06 hobbes NetworkManager: <WARN> 
nm_system_device_get_system_config(): Network configuration for device 'wlan0'
was invalid (non-DHCP configuration, but no IP address specified.  Will use DHCP
Dec  4 22:38:06 hobbes NetworkManager: <info>  wlan0: Device is fully-supported
using driver 'iwl3945'.
Dec  4 22:38:06 hobbes NetworkManager: <info>  (wlan0): exporting device as
Dec  4 22:38:06 hobbes NetworkManager: <info>  Now managing wireless (802.11)
device 'wlan0'.
Dec  4 22:38:06 hobbes NetworkManager: <info>  Bringing up device wlan0
Dec  4 22:38:06 hobbes kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec  4 22:38:06 hobbes NetworkManager: <info>  Deactivating device wlan0.

I ran into a blog post where the author suggested this workaround:

sudo /sbin/service NetworkManager restart
sudo /sbin/service NetworkManager stop
sleep 12
sudo /sbin/service NetworkManager start

This works sometimes, maybe once or twice, after which it either stops doing
anything, or I run into other suspend/resume problems and can't use the laptop.
(but those are other bugs)

How reproducible:

Usually happens within one or two suspend/resume cycles.

Additional info:

Smolt hardware profile available here:

Please feel free to request any other info, this is everything I could think of
so far.
Comment 1 Dan Williams 2007-12-05 10:14:05 EST
When this happens, can you try doing the following (as root) without restarting

/sbin/iwlist wlan0 scan

and see if networks start showing up.  Thanks!
Comment 2 Warren Togami 2007-12-05 11:20:44 EST
This happened to me last night.  iwlist scan did indeed see my desired access
point, but NetworkManager remained blissfully unaware.

Tried rmmod iwl3945; modprobe iwl3945;
iwlist scan again saw my AP, but NetworkManager remained unaware.
Restarting both iwl3945 and NetworkManager made it work again.

Comment 3 Devan Goodwin 2007-12-05 21:44:34 EST
Trying to replicate this tonight and it took me a good 8 to 10 cycles before I
had wireless problems on resume, in this case:

(root@hobbes)[~] # /sbin/iwlist wlan0 scan
wlan0     Failed to read scan data : Resource temporarily unavailable

In this case however my workaround from earlier did not work. I was unable to
get wireless back at all.

Tried another 4 or 5 cycles and unable to get the problem to re-occur. No idea
why it's working better today than yesterday, no package upgrades have been done.
Comment 4 Dan Williams 2007-12-06 05:57:30 EST
The "Failed to read scan data" thing is certainly a driver bug; I've gotten it
on 4965 quite often after poking the rfkill switch too much; haven't been able
to debug it further than that.  You might be able to set up a modprobe option to
turn on debugging information and see what the driver thinks its doing.  See if
you can rmmod the module and modprobe it again and see if that fixes things
right after resume.  If it does, it's certainly a driver issue.
Comment 5 Devan Goodwin 2007-12-31 22:36:45 EST
This might be worth closing, I've been using the laptop heavily lately and the
wireless networks almost always appear on resume. (may have happened once or
twice but I simply cannot reproduce it reliably anymore)
Comment 6 Dan Williams 2008-04-10 17:50:09 EDT
What's your kernel version, just for kicks?

Note You need to log in before you can comment on or make changes to this bug.