Bug 41150 - (Trident Cyber 9397) with LCD display failure
(Trident Cyber 9397) with LCD display failure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 16:08 EDT by Mike Hughes
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-09 03:20:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log produced by startx (12.17 KB, text/plain)
2001-05-23 16:15 EDT, D. Hugh Redelmeier
no flags Details

  None (edit)
Description Mike Hughes 2001-05-17 16:08:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; I)

Description of problem:
Trident Cyber 9397 controller Identified correctly during install but shows only a narrow stripe down the right side of the display, rest of
screen dark.  Works correctly with 3.3.6 SVGA server.  Used "Generic Laptop display 1024x768".

How reproducible:
Always

Steps to Reproduce:
1.Laptop installation on Gateway "Solo" 9100 laptop with default choices during video configuration
2.
3.
	

Actual Results:  Narrow strip of GNOME desktop shows along right edge of display, rest dark.  Image not distorted.

Additional info:
Comment 1 D. Hugh Redelmeier 2001-05-23 16:15:21 EDT
Created attachment 19451 [details]
log produced by startx
Comment 2 D. Hugh Redelmeier 2001-05-23 16:22:08 EDT
The attachment I just added was actually meant for another bug report (sorry!).
That bug report is related: 42033 "XFree86 version 4.0.3 doesn't work for my
Trident Cyber 9388".
Comment 3 Mike A. Harris 2001-05-24 16:59:13 EDT
You say that it works fine with the 3.3.6 SVGA server, but have filed it as
a bug against 3.3.6..  ???

If this is a 4.x bug, please change the component to XFree86.

I need your configuration files, and a server log to analyze.
Comment 4 D. Hugh Redelmeier 2001-05-24 17:43:55 EDT
Mike: I'm not sure who you are addressing.
I didn't realize that 7.1 included the 3.3.6 servers as well.  It is clear to me
that this report and my own (42033) refer to the 4.0.3 trident server.  There
isn't one in 3.3.6 (tridents use the SVGA server in 3.3.6).

So: 4.0.3 trident server doesn't work but 3.3.6 SVGA server does.

My bug report contains log and config file for the 4.0.3 setup.  As a bonus, I
accidentally put the log on this bug report too!
Comment 5 Mike A. Harris 2001-05-24 18:04:56 EDT
XFree86-Servers - which this bug report is filed against, is the
XFree86-Servers-3.3.6-* packages which is for XFree86 3.3.6.  When someone
files against XFree86-Servers, then it is a 3.3.6 bug.  If not, and there
is conflicting information, I can't read minds, and need clarification.
Until the original poster changes this to "XFree86" - if it is a 4.x bug,
then I leave it here as a 3.3.6 bug.  I've changed things before from
assuming things, and have found it best to let the poster fix any errors
in their bug report.
Comment 6 Mike Hughes 2001-05-24 20:26:04 EDT
The catagory just said "Xfree86-Servers" when I made the entry and that made sense to me.  The subject line should make it clear that the
problem is with the version 4 "Trident" Server as supplied with the 7.1 release.  My apologies if it is in the wrong place.

I have had so many problems with the 7.1 release that I deleted it and restored my 6.2 system from the backup.  I can no longer
supply the configuration files.  It did not work either as a "clean" install of 7.1 or as an upgrade from 6.2.  Clear the report if it is of
no help to you.
Comment 7 Mike A. Harris 2001-08-09 17:39:45 EDT
Well, the 3.3.6 Server that is in Red Hat Linux 6.2 is also in Red Hat
Linux 7.* for compatibility purposes.  So you should have been able
to use XFree86 3.3.6 in 7.1 by doing:

Xconfigurator --preferxf3 --nodri

In order to fix this problem however, debugging data needs to be gathered,
or else the problem will never go away, and when 3.3.6 is no longer
supported, the hardware that it supports that 4.x doesn't won't be
supported either.

I'll leave this report open in case you decide to try again.  Remember,
you can use 3.3.6 with 7.1 as above, so you can test 4.x and give
me the config and logfile I need if you like.  At least let me know
your status.

Thanks.
Comment 8 Mike A. Harris 2002-02-09 03:20:25 EST
Just an update to this problem report.  XFree86 4.x has never supported
trident video hardware very well.  This is quite unfortunate for trident
video hardware owners, but the reason is mostly because Trident does not
openly release the specifications for their video hardware.  We do not
have any Trident video hardware nor specifications, so it is particularly
difficult for Red Hat to troubleshoot/debug and hopefully fix any
Trident related bugs as a result.

When something worked before, and doesn't in a newer release, it is
generally because the upstream release has changed something in the code
that broke it, rather than something Red Hat has changed.

That is the bad news.  The good news is that Red Hat now employs the
main author of the XFree86 Trident driver.  This makes it much more
possible for reported Trident bugs to stand a chance at getting
fixed, however he still has limited access to hardware and documentation
as I understand it, which is basically why the support is not very good at
this time.

If you are interested in trying to test out our latest release, and try
various options in a troubleshooting session, I would be more than
glad to go through the various steps with you, and try to narrow the
problems down.

XFree86 4.2.0 is released now, and available in Red Hat rawhide also,
which contains many Trident fixes, and might possibly work for you.

If you are interested in troubleshooting this further, we could
possibly find a solution, and if not, perhaps a decent workaround.

Thanks.
Comment 9 Mike A. Harris 2002-04-05 21:31:02 EST
This is believed to be fixed in 4.2.0-6.53 and later in rawhide

Note You need to log in before you can comment on or make changes to this bug.