Bug 41151 - outgoing smtp on localhost fails when using tcpwrappers
Summary: outgoing smtp on localhost fails when using tcpwrappers
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 20:32 UTC by Tim Brooks
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-15 19:10:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Brooks 2001-05-17 20:32:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
When trying to send e-mail to an smtp server running on 7.1 with tcp
wrappers enabled (i.e. /etc/hosts.deny --> ALL: ALL), the netscape client
will not send on the localhost.  The only way to get this to function was
to put in the line: sendmail : ALL in /etc/hosts.allow.  The following
lines did not work in /etc/hosts.allow:
ALL: localhost
sendmail: localhost

How reproducible:
Always

Steps to Reproduce:
1.Send an e-mail from netscape
2.
3.
	

Actual Results:  I received an error from Netscape:
The mail server responded
5.0.0 Access Denied

/var/log/maillog gave me the following error:

May 17 15:11:15 mailx sendmail[25415]: f4HKBF125415: tcpwrappers
(mailx.personalcarehmo.com, 127.0.0.1) rejection

Expected Results:  e-mail should have been sent

Additional info:

Comment 1 kreucher 2001-06-04 19:50:24 UTC
same problem here, except with fetchmail.

fetchmail -v reports "Access Denied" from the local
sendmail.

adding sendmail: ALL in /etc/hosts.allow worked for me too,
this is alright though, since DomainPortOptions in sendmail.cf
is locked to 127.0.0.1 anyway.

very strange.

Comment 2 Michael Schwendt 2001-06-15 19:10:35 UTC
What about this?

# /etc/hosts.allow
sendmail: LOCAL




Comment 3 Florian La Roche 2001-07-06 09:13:33 UTC
sendmail rpm should be fine.

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.