Bug 41154 - 2.4.3-5 - unresolved symbol in toshiba.o
2.4.3-5 - unresolved symbol in toshiba.o
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 17:34 EDT by Alexei Podtelezhnikov
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 02:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2001-05-17 17:34:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-5 i686)

Description of problem:
While checking module dependencies athlon variant of the kernel 2.4.3-5
complains about unresolved symbols in toshiba.o.  Not sure if i686 does
that too. 

Also, my Viper chipset has been blacklisted for usb-uhci.o which fails to
load and complains about it. I hope this is no mistake, because that never
happened with 2.4.2-2 and earlier.

How reproducible:
Always

Steps to Reproduce:
1. Booting 2.4.3-5.athlon on Viper chipset 
2.
3.
	

Additional info:
Comment 1 Arjan van de Ven 2001-05-18 03:47:25 EDT
Regarding the toshiba module: That module is disabled in the .config of the
athlon kernel, and should therefore not be in the RPM. Could you see with

rpm -qf <filename>

which rpm owns that file ?

Regarding the chipset blacklist: AMD has confirmed the chip doesn't work and
corrupts data if used.
Comment 2 Alexei Podtelezhnikov 2001-05-21 02:47:57 EDT
I assume toshiba.o wasn't removed during update from i686 type to athlon one of 
the same 2.4.3-5. I used rpm -Uvh --ignorearch --force. This was the only 
option combination which worked. Without --force I just received tons on errors 
and failure. It's too bad that such switching between kernels is so painful.

BTW, I think it makes sense to use /lib/modules/2.4.3-5.athlon 
and /lib/modules/2.4.3-5.i686 to avoid conflicts and allow people to have both 
versions at the same time.

Note You need to log in before you can comment on or make changes to this bug.