Bug 411661 - Fedora 8 can not identify Intel 82575EB Gigabit Network controller.
Fedora 8 can not identify Intel 82575EB Gigabit Network controller.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 418441
  Show dependency treegraph
 
Reported: 2007-12-05 03:56 EST by austin
Modified: 2008-04-23 21:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 21:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description austin 2007-12-05 03:56:53 EST
Description of problem:
Fedora 8 can not identify Intel 82575EB Gigabit Network controller. This 
controller used igb.ko as driver and with 10a7 as device id. 

Version-Release number of selected component (if applicable):


How reproducible:
Always, the installation process can not identify the NIC and after 
installation, the system can not identify the NIC. I see this issue under 
Intel Stoakley Platform with Harpertown processor and  Intel Corporation 
82575EB Gigabit Ethernet controller. But due to the failure in finding this 
device and the lack of igb driver, it should be general bug for all machine 
with this NIC.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
lspci show:
...
08:00.0 Ethernet controller: Intel Corporation Unknown device 10a7 (rev 02)
08:00.1 Ethernet controller: Intel Corporation Unknown device 10a7 (rev 02)
...

Expected results:
The system can identify the device and load the avaliable driver (igb.ko).

Additional info:
Comment 1 Geoff Gustafson 2007-12-05 11:31:43 EST
FYI there are three of these Stoakley systems in Westford.
Comment 2 Eric Sandeen 2007-12-06 23:15:49 EST
e2fsprogs?  ah, no.  :)
Comment 3 austin 2008-02-13 02:27:21 EST
The device can be identified in Fedora 9, but F9 didn't integrated igb driver
yet.
Comment 4 Dave Krynick 2008-02-25 04:13:10 EST
This can be worked around by downloading the driver source from Intel's WEB
site. Be sure you get the igb driver. It's a tar.gz file and can be manually
installed by following the instructions in the readme file included in the
download. Installation does require prior installation of the kernal-devel RPM
module. Once installed and the system rebooted, Fedora should find the devices. 

Note-This is one of these "chicken/egg" problems, since you can't download
anything if the NIC doesn't work. To work around this, I installed a cheep NIC
card to do the downloads. 
Comment 5 austin 2008-02-25 04:34:17 EST
Any plan to integrated igb driver into Fedora 9 release?
Comment 6 Dave Jones 2008-02-25 11:05:22 EST
It's enabled in the current F9 builds, but this bug-report is for F8.
F8 won't get a 2.6.25 kernel until after its released.
Comment 7 austin 2008-02-25 21:59:33 EST
Thanks for your answer. If the driver was integrated into F9 beta (F9 alpha 
didn't have it), I will close this bug. 
Comment 8 austin 2008-04-22 21:50:12 EDT
F9 had integrated igb driver correctly, verified. 
Thanks!

Note You need to log in before you can comment on or make changes to this bug.