Bug 41170 - inc doesn't prompt for a password when using pop
inc doesn't prompt for a password when using pop
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: nmh (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 19:22 EDT by Ian Mortimer
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 04:33:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to build nmh with builtin ruserpass function. (507 bytes, patch)
2001-05-17 19:23 EDT, Ian Mortimer
no flags Details | Diff

  None (edit)
Description Ian Mortimer 2001-05-17 19:22:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
The man page for inc says:

       When using POP, you will normally need to type  the  pass-
       word  for  your  account  on  the  POP server, in order to
       retrieve your messages.

However if you run `inc -host pop_server' it doesn't prompt for a password
   
The problem seems to be not with nmh itself but with the system ruserpass
function.
Anyway the simple fix (not necessarily the best) is to apply the attached
patch which builds inc with ruserpass included in the nmh distribution. 


How reproducible:
Always

Steps to Reproduce:
1. inc -host pop_server
2.
3.
	

Actual Results:  inc doesn't prompt for a password and after a delay
reports:

   inc: -ERR [AUTH] Password supplied for "user" is incorrect.

Expected Results:  inc should display:

Password (pop_server:user):

and after (correct) entry of the password retrieve the user's mail from the
pop server.

Additional info:

nmh built on other OSes (Compaq Tru64 Unix for example) works correctly
presumably because it defaults to using the builtin ruserpass in the
absence of a system supplied function.

The builtin ruserpass calls getpass which is a deprecated function.  From
getpass(1):

   This function is obsolete. Do not use it.

If it's obsolete that probably means there's something better but I don't
know what and don't have time to investigate further. 

The workaround is to create a .netrc file with the user name and password
but
in this environment it's not acceptable to ask users to put passwords in a
plain text file.
Comment 1 Ian Mortimer 2001-05-17 19:23:31 EDT
Created attachment 18833 [details]
Patch to build nmh with builtin ruserpass function.

Note You need to log in before you can comment on or make changes to this bug.