Bug 411701 - O_EXCL breaks CD ripping in KDE
Summary: O_EXCL breaks CD ripping in KDE
Status: CLOSED DUPLICATE of bug 206847
Alias: None
Product: Fedora
Classification: Fedora
Component: cdparanoia   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-05 09:35 UTC by Mary Ellen Foster
Modified: 2008-05-15 03:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 03:58:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 135669 None None None Never

Description Mary Ellen Foster 2007-12-05 09:35:25 UTC
Description of problem:
On Fedora, cdparanoia has been compiled with O_EXCL since, it seems, 2003. This
causes problems when ripping CDs in KDE: when you put in a CD, a kio_audiocd
process is started, which means cdparanoia can't access the drive until you kill
the kio_audiocd. The full details are described upstream at
http://bugs.kde.org/show_bug.cgi?id=135669

Version-Release number of selected component (if applicable):
cdparanoia-alpha9.8-27.2

How reproducible:
Every time

Steps to Reproduce:
1. Insert a music CD
2. Open kaudiocreator
3. Try to rip the tracks
  
Actual results:
A message about how cdparanoia can't access the tracks

Expected results:
Ripping the tracks

Additional info:
Running "killall kio_audiocd" after inserting the CD makes things work.

This seems to be related to bug 206847 -- it's a different thing that O_EXCL
breaks. Feel free to close this as a duplicate of the other one, but please look
into fixing this somehow.

Comment 1 Jon Stanley 2008-05-15 03:58:43 UTC

*** This bug has been marked as a duplicate of 206847 ***


Note You need to log in before you can comment on or make changes to this bug.