Bug 41190 - Run as Root does not work
Run as Root does not work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdeadmin (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 21:34 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 14:40:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-17 21:34:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686; Nav)

Description of problem:
When running any of the control panel functions in KDE, when the dialogue
for "run as root" comes up, password is accepted and nothing happens.

How reproducible:
Always

Steps to Reproduce:
1.  Open control panel	
2.  Set the time Zone
3.  Type root password
Nothing	

Actual Results:  Nothing.  I also don't see any processes that I can
recognize
with ps -aux

Additional info:

I have several installations, and I think think this used to work.
Comment 1 Bernhard Rosenkraenzer 2001-05-18 06:09:23 EDT
I can't reproduce this. Make sure kdesu (from kdebase) is installed.
Comment 2 Need Real Name 2001-05-21 17:31:32 EDT
Sorry, but saying you can't duplicate it doesn't help much. 

 I have localized the 
problem to one particular machine, and it may have something to do with the
x-server. 
I ran one of the "run as root" applications in a window, and got the error--

 Xlib:  extension "RENDER" missing on display ":0.0". 

Evidently when the application is run in a window, it gets around this, as you
get the
error and then the window does open.  In the "run as root" with the
"shortcut" , it evidently fails.  

This was an upgrade of a working 6.2 to a 7.1

Comment 3 Bernhard Rosenkraenzer 2001-05-22 14:40:35 EDT
Are you sure you installed the applications you want to launch?
kontrol-panel currently displays all applications it can launch all the time, 
and should simply tell you "you need to install the xxxxx package" if you try 
to launch something that isn't installed. It's possible that the error 
reporting is broken.
Comment 4 Need Real Name 2001-05-22 15:10:16 EDT
Yes, the applications work fine, as they will run when you are logged in as
root.

Evidently I didn't make myself clear-- 

1.  the problem is when you run as a user,
and you select an application that must be run as root (i.e. something in the
control
panel) by clicking the icon in the control panel, it asks for the root password
and
then does nothing.

2.  If you then type the same command into a window, (that the icon is
executing) you get the ----  RENDER missing  extension error.

3.  If you log in as root, all the applications work.


---------------------------------------

At this point, this isn't worth the time to work on it. 

 I have assigned it to WONTFIX as
this feature works on my other 7.1 installations and it seems like we are going
to
be going back and forth for a long time.
Comment 5 Bernhard Rosenkraenzer 2001-05-23 03:15:32 EDT
I know about 1.; I can't reproduce it though. My guess is that for some 
reason, kdesu can't give root access to the X server. Does this still happen 
if you run "xhost +localhost" before running kontrol-panel?

2. doesn't have anything to do with the problem. It just means you're using a 
graphics card that doesn't support antialiasing.


Note You need to log in before you can comment on or make changes to this bug.