Bug 41209 - cirrus driver fails on graphical install
Summary: cirrus driver fails on graphical install
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-18 06:36 UTC by bill parducci
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-24 21:20:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulled from /tmp/ while X was wanking (during install) (3.94 KB, text/plain)
2001-05-24 20:54 UTC, bill parducci
no flags Details
pulled from /tmp/ while X was wanking (during install) (10.07 KB, text/plain)
2001-05-24 20:55 UTC, bill parducci
no flags Details
Fixes bug in Cirrus driver in 4.0.3 with missing symbols (632 bytes, patch)
2001-05-24 22:20 UTC, Mike A. Harris
no flags Details | Diff

Description bill parducci 2001-05-18 06:36:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
there is a bug in the video driver (cirrus) associated with the machines i
am using
(compaq prosignia 200). upon xwindows startup, this are the errors i get:

symbol vbeDoEDID from module /usr/X11R6/lib/modules/drivers/cirrus.o is
unresolved!

symbol VBEInitScreens from module
/usr/X11R6/lib/modules/extensions/libdri.ais unresolved!

the 'gray' screen with the X cursor comes up, then it goes black. you can
see that there are some memory issues 'cuz you sometimes you see the gray
screen with multicolored bars and/or the compaq boot logo interspersed in
it.

neither low res nor nofb helps. the driver iseems to be used even in
640x480 mode.

How reproducible:
Always

Steps to Reproduce:
1. get a compaq prosignia 200
2. put in redhat cd
3. press 'enter' for default install
	

Actual Results:  black screen

Expected Results:  anaconda gui should come up

Additional info:

vanilla redhat 7.1 cd

Comment 1 Brent Fox 2001-05-18 19:25:24 UTC
This looks like an X bug, so I'm changing the component.

Comment 2 Mike A. Harris 2001-05-24 04:20:40 UTC
I need you to attach your /etc/X11/XF86Config* files and your
/var/log/XFree86.0.log logfile to the bug report using the file
attachment link below.

Comment 3 bill parducci 2001-05-24 05:30:15 UTC
hmm, i have it up and running via the text install. unfortunately i can't use
Xconfigurator to generate config files since i didn't install any X on the box
(it's a server, who needs X?) the only reason i was trying to use the X install
is because the text install can't handle raid drives! let me see what i can dig
up.

Comment 4 bill parducci 2001-05-24 20:54:53 UTC
Created attachment 19550 [details]
pulled from /tmp/ while X was wanking (during install)

Comment 5 bill parducci 2001-05-24 20:55:44 UTC
Created attachment 19552 [details]
pulled from /tmp/ while X was wanking (during install)

Comment 6 Mike A. Harris 2001-05-24 21:23:33 UTC
Found cause of error, should be fixed in XFree86-4.0.3-17, available at:

ftp://people.redhat.com/mharris/testing

Should be there in a day or so.

Comment 7 bill parducci 2001-05-24 22:03:38 UTC
will test and respond when patch is available.

Comment 8 Mike A. Harris 2001-05-24 22:18:05 UTC
It's building right now, but if you'd like the patch, I'll attach it right now..
Here you go..

Comment 9 Mike A. Harris 2001-05-24 22:20:19 UTC
Created attachment 19557 [details]
Fixes bug in Cirrus driver in 4.0.3 with missing symbols


Note You need to log in before you can comment on or make changes to this bug.