Bug 412121 - Following recent Update, CPAN fails with does not match executable architecture
Following recent Update, CPAN fails with does not match executable architecture
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 10:06 EST by Ian
Modified: 2008-02-22 03:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 03:18:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian 2007-12-05 10:06:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; InfoPath.2)

Description of problem:
Just run install the latest updates via yum : 

Dec 05 14:06:40 Updated: firefox - 2.0.0.10-2.fc8.i386
Dec 05 14:06:43 Updated: selinux-policy - 3.0.8-62.fc8.noarch
Dec 05 14:06:51 Updated: firefox-devel - 2.0.0.10-2.fc8.i386
Dec 05 14:06:52 Updated: yum - 3.2.7-2.fc8.noarch
Dec 05 14:06:54 Updated: kernel-headers - 2.6.23.8-63.fc8.i386
Dec 05 14:07:06 Installed: kernel-devel - 2.6.23.8-63.fc8.i686
Dec 05 14:07:09 Updated: coreutils - 6.9-11.fc8.i386
Dec 05 14:07:11 Updated: sendmail - 8.14.2-1.fc8.i386
Dec 05 14:07:15 Updated: libwvstreams - 4.4.1-1.fc8.i386
Dec 05 14:07:17 Updated: gphoto2 - 2.4.0-4.fc8.i386
Dec 05 14:07:17 Updated: ntfsprogs - 1.13.1-8.fc8.i386
Dec 05 14:07:40 Installed: kernel - 2.6.23.8-63.fc8.i686
Dec 05 14:07:41 Updated: rsyslog - 1.19.11-1.fc8.i386
Dec 05 14:07:42 Updated: at - 3.1.10-18.fc8.i386
Dec 05 14:07:42 Updated: ntfs-3g - 2:1.1120-1.fc8.i386
Dec 05 14:07:42 Updated: sendmail-devel - 8.14.2-1.fc8.i386
Dec 05 14:07:44 Updated: sendmail-cf - 8.14.2-1.fc8.i386
Dec 05 14:08:10 Updated: selinux-policy-devel - 3.0.8-62.fc8.noarch
Dec 05 14:08:54 Updated: selinux-policy-targeted - 3.0.8-62.fc8.noarch
Dec 05 14:08:54 Updated: NetworkManager-glib - 1:0.7.0-0.6.6.svn3109.fc8.i386
Dec 05 14:08:56 Updated: NetworkManager - 1:0.7.0-0.6.6.svn3109.fc8.i386
Dec 05 14:08:56 Updated: perl-libs - 4:5.8.8-32.fc8.i386
Dec 05 14:09:03 Updated: perl - 4:5.8.8-32.fc8.i386
Dec 05 14:09:05 Updated: NetworkManager-gnome - 1:0.7.0-0.6.6.svn3109.fc8.i386
Dec 05 14:09:05 Updated: perl-Test-Harness - 2.56-32.fc8.i386
Dec 05 14:09:06 Updated: perl-devel - 4:5.8.8-32.fc8.i386
Dec 05 14:09:07 Updated: perl-ExtUtils-MakeMaker - 6.30-32.fc8.i386
Dec 05 14:09:07 Updated: perl-ExtUtils-Embed - 1.26-32.fc8.i386
Dec 05 14:09:07 Updated: perl-CPAN - 1.76_02-32.fc8.i386


Now when using CPAN, the following error occurs : 

Going to read /root/.cpan/Metadata
  Database was generated on Mon, 03 Dec 2007 02:39:06 GMT
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
  ftp://cpan.etla.org/pub/CPAN/authors/01mailrc.txt.gz
LWP failed with code[500] message[Errno architecture (i386-linux-thread-multi-2.6.20-1.2952.fc6) does not match executable architecture (i386-linux-thread-multi-2.6.20-1.3001.fc6xen) at /usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/Socket.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/Socket.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/LWP/Protocol/ftp.pm line 24.
]
Fetching with Net::FTP:
  ftp://cpan.etla.org/pub/CPAN/authors/01mailrc.txt.gz
Can't locate object method "new" via package "Net::FTP" at /usr/lib/perl5/5.8.8/CPAN.pm line 2250.



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.  perl -MCPAN -e shell
2.  instal xxx:xxx
3.

Actual Results:
Going to read /root/.cpan/Metadata
  Database was generated on Mon, 03 Dec 2007 02:39:06 GMT
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
  ftp://cpan.etla.org/pub/CPAN/authors/01mailrc.txt.gz
LWP failed with code[500] message[Errno architecture (i386-linux-thread-multi-2.6.20-1.2952.fc6) does not match executable architecture (i386-linux-thread-multi-2.6.20-1.3001.fc6xen) at /usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/Socket.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/Socket.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/LWP/Protocol/ftp.pm line 24.
]
Fetching with Net::FTP:
  ftp://cpan.etla.org/pub/CPAN/authors/01mailrc.txt.gz
Can't locate object method "new" via package "Net::FTP" at /usr/lib/perl5/5.8.8/CPAN.pm line 2250.



Expected Results:


Additional info:
Comment 1 Marcela Mašláňová 2008-02-18 09:27:21 EST
> From Bugzilla Helper:
> User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Mozilla/4.0 
> (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; Media 
> Center PC 5.0; .NET CLR 3.0.04506; InfoPath.2)
From the bugzilla I'm little confused, what are you using. 

The problem is probably here: 
WP failed with code[500] message[Errno architecture
(i386-linux-thread-multi-2.6.20-1.2952.fc6) does not match executable
architecture (i386-linux-thread-multi-2.6.20-1.3001.fc6xen) 

Are you using xen virtual machine for your CPAN? I didn't use xen, but as I see
you have two different directories on your computer.
Comment 2 Ian 2008-02-21 11:30:57 EST
it's been some time since the original request was raised and looked liked a 
3rd party RPM install a different version of Scalar::Util.

I managed to 'fix' this by removing the architecture check.

I cannot report as FIXED - but you can close down the Request

thanks

Note You need to log in before you can comment on or make changes to this bug.