Bug 412201 - Missing product-version in channel export
Missing product-version in channel export
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Amy Owens
US=17469
:
Depends On:
Blocks: 446437
  Show dependency treegraph
 
Reported: 2007-12-05 10:35 EST by Miroslav Suchý
Modified: 2013-01-10 04:16 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 16:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2007-12-05 10:35:58 EST
Description of problem:
Channel export is missing product-version. We need it at least for proxy channel.
There is product name e.g.
<rhn-channel-product-name>proxy</rhn-channel-product-name>
but we need also something like 
<rhn-channel-product-version>3.7</rhn-channel-product-version>
and
<rhn-channel-product-beta>N</rhn-channel-product-beta>
The Beta is optional, because we really do not need it, but data schema has it.

Data is already in RHNCHANNELPRODUCT, so we need to modify only exporter.

Version-Release number of selected component (if applicable):
503

How reproducible:
always
Comment 1 Miroslav Suchý 2008-03-11 05:39:58 EDT
Brandon wrote:
Please take a quick look at Bugzilla Bug 412201: "Missing
product-version in channel export".  I'm curious if this is still an
issue, or if it was resolved once all the taxonomy stuff was
straightened out?  I didn't look because from the description I couldn't
figure out what the test plan would be.  I'm looking at this because it
indirectly blocks the Proxy 5.1 release.

What I'd like to see is:

A) if this bug is still valid, and
B) a test plan to verify that the bug is fixed
Comment 2 Miroslav Suchý 2008-03-11 05:47:19 EDT
This is IMHO easiest way to verify:

Apply this patch
--- ./server/importlib/backend.py.orig  2008-03-11 10:57:36.000000000 +0100
+++ ./server/importlib/backend.py       2008-03-11 10:57:45.000000000 +0100
@@ -1044,7 +1044,9 @@
         # this should be probably done for others products as well
         # well this is just temporary workaround
         # can be safely removed when BZ 412201 is fixed
+        print "dbg %s" % channel
         if channel['product_name'] == 'proxy':
+            print "dbg2 %s" % channel
            m = re.match(r'Red Hat Network Proxy \(v(\d+.\d+) .+\)',
channel['name'])
             channel['channel_product'] = channel['product_name']
             channel['channel_product_version'] = m.group(1)

and check if in output is present keys: channel_product,
channel_product_version. I just run it (against webqa) and it is still not
there. So this bug is still valid.

More corect way to verify this bug is to apply this patch:
--- ./server/importlib/backend.py.origve2008-03-11 10:57:36.000000000
+0100r/importlib/backend.py
+++ ./server/importlib/backend.py/server2008-03-11 11:04:18.000000000 +0100/impor
@@ -1041,15 +1041,6 @@

     def processChannelProduct(self, channel):
         """ Associate product with channel """
-        # this should be probably done for others products as well
-        # well this is just temporary workaround
-        # can be safely removed when BZ 412201 is fixed
-        if channel['product_name'] == 'proxy':
-           m = re.match(r'Red Hat Network Proxy \(v(\d+.\d+) .+\)',
channel['name'])
-            channel['channel_product'] = channel['product_name']
-            channel['channel_product_version'] = m.group(1)
-            channel['channel_product_beta'] = 'N'
-        # end of safe remove in future

         channel['channel_product_id'] = self.lookupChannelProduct(channel)

And then verify that tool rhn-proxy-activate works.
Note: this patch must be applied *before* syncing proxy channel, if you want it
to verify.
Comment 3 Amy Owens 2008-05-14 12:37:11 EDT
moving to sprint 8
Comment 4 Amy Owens 2008-05-27 13:07:58 EDT
notes to test -(12:23:32 PM) jbowes: you can also do a satellite sync, then look
on scripts, in /var/cache/rhn/xml-channels at the generated xml file, and verify
the new parts are there
Comment 6 James Bowes 2008-05-28 10:24:29 EDT
Looks like it is dying on a channel without taxonomy.
Comment 7 Amy Owens 2008-05-28 15:33:41 EDT
on dev now:<rhn-channel channel-arch="channel-ia32"
channel-errata="rhn-erratum-18972 rhn-erratum-19103" kickstartable-trees=""
label="jbowes-rhel-i386-server-supplementary-5" packages="rhn-package-469892
rhn-package-471041"
channel-id="rhn-channel-37532"><rhn-channel-parent-channel>rhel-i386-server-5</rhn-channel-parent-channel><rhn-channel-basedir>/</rhn-channel-basedir><rhn-channel-name>jbowes
RHEL Supplementary (v. 5 for 32-bit
x86)</rhn-channel-name><rhn-channel-summary>jbowes Red Hat Enterprise Linux
Supplementary Software (v. 5 for 32-bit x86
Server)</rhn-channel-summary><rhn-channel-description>jbowes Red Hat Enterprise
Linux - Server supplementary software with non-standard SLAs and/or licenses (v.
5 for 32-bit
x86)</rhn-channel-description><rhn-channel-gpg-key-url>file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release</rhn-channel-gpg-key-url><rhn-channel-receiving-updates>Y</rhn-channel-receiving-updates><rhn-channel-last-modified>1211995049</rhn-channel-last-modified><rhn-channel-product-name>supplementary</rhn-channel-product-name><rhn-channel-product-version>5</rhn-channel-product-version><rhn-channel-product-beta>N</rhn-channel-product-beta><rhn-channel-families><rhn-channel-family
virt-sub-level-name="Virtualization free content group,Virtualization Platform
free content group" channel-labels="rhel-i386-as-3-extras rhel-i386-es-3-extras
rhel-ia64-as-3-extras rhel-ia64-es-3-extras rhel-x86_64-as-3-extras
rhel-x86_64-es-3-extras rhel-ppc-as-3-extras rhel-i386-as-4-extras
rhel-i386-es-4-extras rhel-x86_64-as-4-extras rhel-x86_64-es-4-extras
rhel-ia64-as-4-extras rhel-ia64-es-4-extras rhel-ppc-as-4-extras
rhel-i386-server-supplementary-5 rhel-x86_64-server-supplementary-5
rhel-ia64-server-supplementary-5 rhel-ppc-server-supplementary-5
jbowes-rhel-i386-server-supplementary-5"
virt-sub-level-label="virtualization_free virtualization_platform_free"
id="rhn-channel-family-5491"
label="rhel-server-supplementary"/></rhn-channel-families><rhn-dists/><source-packages/><rhn-channel-errata><erratum
last-modified="1211989424" id="rhn-erratum-18972"
advisory-name="RHEA-2008:9999AGAINJBOWESSTGIT"/><erratum
last-modified="1211995049" id="rhn-erratum-19103"
advisory-name="RHEA-2008:9999JBOWESYUMUTILS"/></rhn-channel-errata><rhn-release/></rhn-channel>
Comment 8 Grant Gainey 2008-06-13 15:12:21 EDT
verified

Note You need to log in before you can comment on or make changes to this bug.