Bug 412241 - host command does not show NXDOMAIN for non-existent reversals
host command does not show NXDOMAIN for non-existent reversals
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 10:56 EST by Frank Sweetser
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9.5.0-20.b1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 10:25:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Sweetser 2007-12-05 10:56:44 EST
bind-utils-9.5.0-18.a7.fc8

Bind on Fedora 7, when told to look up the PTR record for an IP address that
doesn't have one, gave an appropriate error of NXDOMAIN:

[fs@trapeze ~]$ host 130.215.201.99
Host 99.201.215.130.in-addr.arpa. not found: 3(NXDOMAIN)

On Fedora 8, however, it gives a misleading error message that sounds like you
gave it a bad query:

tty/5 1007 erwin 10:52:21 $ host 130.215.201.99
host: '99.201.215.130.in-addr.arpa.' is not a legal name (unexpected end of input)
Comment 1 Adam Tkac 2007-12-10 04:47:14 EST
Yes, regression caused by "IDN" patch
Comment 2 Adam Tkac 2007-12-11 07:24:40 EST
Fix is commited in CVS, will be in next build
Comment 3 Fedora Update System 2007-12-20 14:49:14 EST
bind-9.5.0-20.b1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.