Bug 412251 - Fails to setup network for new install
Fails to setup network for new install
Status: CLOSED DUPLICATE of bug 390991
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 11:04 EST by Bastien Nocera
Modified: 2007-12-05 11:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 11:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-12-05 11:04:56 EST
Using KVM, I've not been able to use virt-manager to create a new virtual
machine. It fails setting up the network bridge (I selected the default network
setup, as I'm on a wireless network handled by NetworkManager).

I get this traceback after the disk image has been created:
Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed Failed to add tap interface 'vnet-1078634840' to
bridge 'virbr0' : No such device
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 616, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 724, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 741, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 573, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed Failed to add tap interface
'vnet-1078634840' to bridge 'virbr0' : No such device
'

virt-manager-0.5.2-2.fc8
python-virtinst-0.300.1-3.fc8
libvirt-python-0.3.3-2.fc8
Comment 1 Daniel Berrange 2007-12-05 11:11:41 EST
What host kernel version are you on ? Rawhide kernel is currently fubar for
bridged networking.
Comment 2 Bastien Nocera 2007-12-05 11:13:36 EST
kernel-2.6.24-0.39.rc3.git1.fc9
Comment 3 Bastien Nocera 2007-12-05 11:14:37 EST
# /usr/sbin/brctl show
bridge name     bridge id               STP enabled     interfaces

and in dmesg:
virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
virbr0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
Comment 4 Daniel Berrange 2007-12-05 11:18:39 EST
Yep, you loose I'm afraid. Bug 390991

*** This bug has been marked as a duplicate of 390991 ***

Note You need to log in before you can comment on or make changes to this bug.