Bug 412281 - problem appered when package updater and add/remove software starting
problem appered when package updater and add/remove software starting
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 11:27 EST by A.Aziz
Modified: 2007-12-29 23:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 23:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
purit bug (1.92 KB, application/octet-stream)
2007-12-05 11:27 EST, A.Aziz
no flags Details
crash dump pirut (1.63 KB, application/octet-stream)
2007-12-27 16:14 EST, Edo-Martijn Janssen
no flags Details

  None (edit)
Description A.Aziz 2007-12-05 11:27:03 EST
When package updater starting an exception occurred appearing also with
add/remove Software


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Component: pirut
Summary: TB8cc68395 repoMDObject.py:102:getData:RepoMDError: requested datatype
primary not available

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
    main()
  File "/usr/sbin/pup", line 610, in main
    pup.run()
  File "/usr/sbin/pup", line 449, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 331, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 296, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 63, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 77, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 242, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 164, in populate
    xml = repo_get_function()
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 868, in getPrimaryXML
    return self.retrieveMD('primary')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 817, in retrieveMD
    thisdata = self.repoXML.getData(mdtype)
  File "/usr/lib/python2.5/site-packages/yum/repoMDObject.py", line 102, in getData
    raise RepoMDError, "requested datatype %s not available" % type
RepoMDError: requested datatype primary not available

Local variables in innermost frame:
self: <yum.repoMDObject.RepoMD instance at 0x91e80cc>
type: primary
Comment 1 A.Aziz 2007-12-05 11:27:03 EST
Created attachment 278491 [details]
purit bug
Comment 2 Edo-Martijn Janssen 2007-12-27 16:14:06 EST
Created attachment 290460 [details]
crash dump pirut

When I start the System Updater I am asked to save the crash dump and sent I
bugreport. Hope this is sufficient. If not, let me know.

Rgds
Edo-Martijn
Comment 3 Jeremy Katz 2007-12-29 23:08:48 EST

*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.