Bug 41230 - xfig: scaling after rotating an ellipse crash linux
xfig: scaling after rotating an ellipse crash linux
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 07:49 EDT by Finn Aarup Nielsen
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 17:03:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
From /var/log/ (21.06 KB, text/plain)
2001-10-15 04:14 EDT, Finn Aarup Nielsen
no flags Details

  None (edit)
Description Finn Aarup Nielsen 2001-05-18 07:49:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i586)

Description of problem:
Drawing an ellipse in xfig, rotating and scaling can trigger an error in
the xserver that crashes the Xserver/linux.

How reproducible:
Always

Steps to Reproduce:
1. Draw an ellipse
2. Rotate the ellipse
3. Scale the ellipse
	

Actual Results:  On a redhat 7.1 system X/Linux hangs with only hardware
reset possible, ie, severe.
On a redhat 7.0 system an extra erroneous line appears - and this is erased
when the window is redrawn, ie, not severe.

Expected Results:  The errorneous line should not be drawn. 

Additional info:

The redhat 7.1 system I have is installed on a computer with onboard
graphics card that uses the ordinary RAM as video RAM. Linux and/or the
Xserver might not be able to handle that properly and xfig is just
triggering an error in that connection, ie., there are both an error in the
Xserver/Linux (or my bios configuration) and in xfig

When I start xfig on an other computer and let the xfig display on the
redhat 7.1 with onboard graphics card the error is still triggered - and
the Xserver/Linux crashes - on the computer with the display - not the
other computer running xfig.
Comment 1 Ngo Than 2001-05-18 17:55:56 EDT
i cannot reproduce this problem on my notebook and my machine.

I will say it's a bug in Xserver. Could you please give more infos about your
graphic card (chipset?)
Comment 2 Mike A. Harris 2001-05-19 10:49:59 EDT
I cannot reproduce this either.  I need your X server logs and your
XF86Config files attached uncompressed using the hyperlink below
Comment 3 Rutger Noot 2001-10-15 03:42:04 EDT
This also happens to me, actually just starting xfig hangs my system. Looks
similar to bug 47650. The system has no time to write any log files, just
freezes. 
The problem depends on the X server, it happens with XFree86 4.0.3 (trident
chipset) but not under XF86_SVGA. I also observed the problem under Mandrake 8.0
(with XFree 4).
Comment 4 Finn Aarup Nielsen 2001-10-15 04:14:57 EDT
Created attachment 34101 [details]
From /var/log/
Comment 5 Finn Aarup Nielsen 2001-10-15 04:27:05 EDT
I can still reproduce the problem. My graphics card is on-board:
"Build S3 Savage4 (86C370) in VT8365(VT8364)" with "Support shared memory
architecture". 

> rpm -qa | grep X
playmidi-X11-2.4-12
Xaw3d-1.5-9
XFree86-4.0.3-5
Xconfigurator-4.9.27-1
XFree86-twm-4.0.3-5
XFree86-libs-4.0.3-5
XFree86-xfs-4.0.3-5
XFree86-100dpi-fonts-4.0.3-5
XFree86-tools-4.0.3-5
XFree86-xdm-4.0.3-5
XFree86-devel-4.0.3-5
XFree86-75dpi-fonts-4.0.3-5
emacs-X11-20.7-34
Xaw3d-devel-1.5-9

I guess the problem might be connected to the shared memory. A line in the XFree
log is:
(WW) SAVAGE(0): Failed to set up write-combining range (0xd0000000,0x2000000)
Comment 6 Mike A. Harris 2001-10-27 18:09:10 EDT
It could help to troubleshoot if you could test something for me:

Does this problem go away if you enable Option "Noaccel" in your
config file, as per the XF86Config man page?
Comment 7 Rutger Noot 2001-10-28 16:08:50 EST
YES, the problem disappears with Option "NoAccel" in the XF86Config-4
(for xfig as well as for xdvi). 

BTW, even with acceleration disabled, XFree 4 still outperforms Xfree 3 on
which the option accel does not work for me. I don't know if this might 
be related: with rh7.0, I could use Option "Accel" with XFree 3.3 (and get some
acceleration) but with the XF3.3 version shipped with rh7.1, the server displays
garbage when I use accel. (That's why I switched to XFree 4)

In case I hadn't mentioned, my controller is a Trident Microsystems|Cyber 9525
on a Toshiba 4090 laptop.
Comment 8 Mike A. Harris 2002-02-09 03:25:52 EST
We have released XFree86 4.1.0-15 as an update for Red Hat Linux 7.1 and 7.2
now.  If you still are experiencing these problems with the server, and
have upgraded to the latest version of XFree86, I would be glad to try
and troubleshoot this issue further.

Please update the report to let me know if this still occurs or not
with 4.1.0-15.  Also XFree86 4.2.0 is available in rawhide which could
possibly solve the problem if 4.1.0-15 doesn't and you feel adventurous
enough to experiment with rawhide.

Either way, let me know how you'd like to proceed.
Comment 9 Rutger Noot 2002-02-11 17:03:48 EST
I just installed rh 7.2 (fresh install) and all updates. 
It looks like XFree86-4.1.0-15 solves my problems! I deleted all XaaNo***
options from XF86Config-4 and did not experience any hangs. 

Also (I did not register this as a bug), I can now suspend (and resume) my
laptop without switching virtual consoles. With this version of XFree, X gets
restored fine on resume.

Note You need to log in before you can comment on or make changes to this bug.