Bug 412421 - liquidwar uses -mcpu in a strange way... Patch included
liquidwar uses -mcpu in a strange way... Patch included
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liquidwar (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 12:02 EST by Oliver Falk
Modified: 2008-01-11 17:19 EST (History)
0 users

See Also:
Fixed In Version: 5.6.4-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:19:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove TARGET_CPU stuff from Makefile... (1.74 KB, patch)
2007-12-05 12:02 EST, Oliver Falk
no flags Details | Diff

  None (edit)
Description Oliver Falk 2007-12-05 12:02:44 EST
On alpha it doesn't even work and on every other arch, CFLAGS should set mcpu
correctly. Therefor patch included. This patch should be ok for all arches.
Comment 1 Oliver Falk 2007-12-05 12:02:44 EST
Created attachment 278541 [details]
Remove TARGET_CPU stuff from Makefile...
Comment 2 Hans de Goede 2007-12-12 16:31:25 EST
Thanks, for the patch, but this is already fixed in rawhide in a more elegant
way: ./configure gets passed --disable-target-opt, which sets $(TARGET_OPT) to
no, resulting in TARGET_CPU_CC getting assigned an empty string as value.
Comment 3 Oliver Falk 2007-12-12 16:59:51 EST
ok hand. can you update f8 to rawhide version?
Comment 4 Hans de Goede 2007-12-12 17:06:49 EST
If that helps those working on an alpha version of Fedora sure, I assume thats
the reason for the request? As I see no immediate benefit for end users.
Comment 5 Oliver Falk 2007-12-12 17:15:54 EST
Yes, that's the reason. I'd like to get as much in sync with F8 as possible :-)
Comment 6 Fedora Update System 2007-12-15 12:45:21 EST
liquidwar-5.6.4-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liquidwar'
Comment 7 Oliver Falk 2007-12-16 16:39:36 EST
Thx. WorksForMe(tm)
Comment 8 Fedora Update System 2008-01-11 17:19:38 EST
liquidwar-5.6.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.