Bug 412711 - Problem with download progress bar
Problem with download progress bar
Status: CLOSED DUPLICATE of bug 437197
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 15:00 EST by Aravind Seshadri
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 13:22:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Download progress bar problem (30.78 KB, image/png)
2007-12-05 15:00 EST, Aravind Seshadri
no flags Details
Problem with installation progress bar (27.60 KB, image/png)
2007-12-05 15:01 EST, Aravind Seshadri
no flags Details
No problem while removing packages (44.23 KB, image/png)
2007-12-05 15:03 EST, Aravind Seshadri
no flags Details

  None (edit)
Description Aravind Seshadri 2007-12-05 15:00:29 EST
Description of problem:
When the terminal windows is re-sized and in particular if the horizontal width
is reduced beyond a certain limit then this problem occurs. With every update of
the percentage progress of the download progress bar [1] (while the package for
installation is being downloaded) and the installation progress bar [2], a new
line is returned. See the attached images for more details. 

Version-Release number of selected component (if applicable):
3.27

How reproducible:
Can reproduce easily

Steps to Reproduce:
1. Start terminal (in GNOME)
2. Re-size the terminal window to have width less than 65 character length
3. run yum install <package> (the <package> is any program that is not already
installed)
  
Actual results:
With each update of the download/installation progress a new line is created.

Expected results:
The progress bar should increase on the same line without creating the new lines.

Additional info:
I do not see the problem which removing packages [3]. 

[1] - Image-1
[2] - Image-2
[3] - Image-3
Comment 1 Aravind Seshadri 2007-12-05 15:00:29 EST
Created attachment 278741 [details]
Download progress bar problem
Comment 2 Aravind Seshadri 2007-12-05 15:01:29 EST
Created attachment 278751 [details]
Problem with installation progress bar
Comment 3 Aravind Seshadri 2007-12-05 15:03:08 EST
Created attachment 278761 [details]
No problem while removing packages
Comment 4 Seth Vidal 2007-12-05 15:08:57 EST
Well, the reason why the erasures work is that there is no 'progress' for
erasures - it's a single output. It's either 0 or 100% for erasures.
Comment 5 Seth Vidal 2008-03-12 12:01:34 EDT
This one is unlikely to be fixed. We'd be adding in a bunch of code just to deal
with < 80char displays.
Comment 6 James Antill 2008-05-14 13:22:25 EDT

*** This bug has been marked as a duplicate of 437197 ***

Note You need to log in before you can comment on or make changes to this bug.