Bug 413031 - ACPI brightness keys broken on Thinkpad T61p
ACPI brightness keys broken on Thinkpad T61p
Status: CLOSED DUPLICATE of bug 363261
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-05 16:59 EST by Brian Long
Modified: 2008-03-11 17:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-11 17:43:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian Long 2007-12-05 16:59:45 EST
Description of problem:
In Fedora8 latest kernel, I cannot use the brightness adjust keys of my Thinkpad
T61p laptop.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Grab a Thinkpad T61 or T61p
2. Press Fn+Home or Fn+End

Actual Results:
Gnome brightness applet moves, but brightness does not change.

Expected Results:
Brightness of the LCD is changed and updated in GNOME brightness applet.

Additional info:
I noticed the ibm-acpi / thinkpad_acpi folks just released a patch which says it
fixes T61 and T61p issues.  It is located here:

I would like to know if you plan to port this into the 2.6.23.x kernel in Fedora
8 since it appears all T61 and T61p laptops are affected.  Thanks!
Comment 1 Chuck Ebbert 2008-02-05 20:29:29 EST
Try adding:


to the kernel boot parameters...
Comment 2 petrosyan 2008-03-11 17:43:12 EDT

*** This bug has been marked as a duplicate of 363261 ***

Note You need to log in before you can comment on or make changes to this bug.