Bug 41318 - system uptime incorrect after 512 days
system uptime incorrect after 512 days
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 14:59 EDT by joe lang
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joe lang 2001-05-18 14:59:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.14-5.0smp i686)

Description of problem:
the system uptime as displayed by w and top (possibly others) is incorrect
after system uptime is greater than 512 days,it wraps back to 0  (mod 512?)

How reproducible:
Always

Steps to Reproduce:
1.boot system
2.drink coffee for 18 months
3.look at system uptime
	

Actual Results:  $ w
  1:42pm  up 18 days, 17:25,  1 user,  load average: 0.00, 0.00, 0.00


Expected Results:  $ w
  1:42pm  up 516 days, 17:25,  1 user,  load average: 0.00, 0.00, 0.00


Additional info:

"top" also displays uptime with the same error, it's not specific to w
It's occuring on more than one system. It's a minor problem, how many
systems
are up for more than 500 days? But when I tried to show the NT sysadmin
what uptime SHOULD look like, the damn thing showed 17 days ;-)
last boot was Dec 19,1999
Comment 1 Daniel Roesen 2001-05-31 10:27:59 EDT
This is somehow not a bug but normal. The internal kernel uptime timer (jiffies)
wraps at around 497 days to 0 (32 bit unsigned integer, counting 100 times per
second on x86). Sad, but true. ;-)

Note You need to log in before you can comment on or make changes to this bug.