Bug 41320 - vim in 7.1 does not properly retrieve search history
Summary: vim in 7.1 does not properly retrieve search history
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-18 19:17 UTC by Ben LaHaise
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 19:17:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben LaHaise 2001-05-18 19:17:53 UTC
Description of Problem:
Attempting to scroll back to an older search pattern in vim results in 
<Up> and <Down> being entered into the search string.  This is wrong.

How Reproducible:
Always.

Steps to Reproduce:
Enter the following:
	vi foo
	/bar
	/<Up-arrow>

Actual Results:
Bottom of screen displays:
	/<Up>

Expected Results:
Bottom of screen displays
	/bar

Comment 1 Bernhard Rosenkraenzer 2001-05-21 10:21:30 UTC
This is because you're using the minimal version of vim.
It's designed to be small, therefore all not absolutely necessary features 
(like remembering search items) are not compiled in.

If you want this feature, use vim-enhanced (install the package and invoke 
/usr/bin/vim, e.g. by setting alias vi=vim).



Comment 2 John Gotts 2001-05-27 19:43:22 UTC
This feature existed in vim-minimal's /bin/vi in Red Hat 7.0 (and all previous
versions of Red Hat) and was removed without warning in 7.1.


Note You need to log in before you can comment on or make changes to this bug.