Bug 41332 - Fails to build with libtool-1.4-2
Fails to build with libtool-1.4-2
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-18 19:05 EDT by Enrico Scholz
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-27 13:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-05-18 19:05:27 EDT
Description of Problem:

XFree86-4.0.99.3-0 fails to build with libtool-1.4-2


Steps to Reproduce:
1. rpm --rebuild XFree86-4.0.99.3-0.src.rpm


Actual Results:
...
/bin/sh ../../libtool --mode=compile gcc -DX11 -fomit-frame-pointer
-funroll-loops -fexpensive-optimizations -ffast-math -DBIG_OPT
-Wall               -I../../../h5/glide3/src -I../../h5/incsrc
-I../../../h5/incsrc -I../../../h5/minihwc -I. -I../../../swlibs/fxmemmap
-I../../../swlibs/fxmisc -I../../../swlibs/newpci/pcilib
-I../../../swlibs/texus2/lib            -O3         -c
../../../swlibs/fxmisc/fx64.c
libtool: ltconfig version `' does not match ltmain.sh version `1.3.5'
Fatal configuration error.  See the libtool docs for more information.
make[2]: *** [fx64.lo] Error 1
make[2]: Leaving directory
`/var/volatile/rpm/BUILD/XFree86-4.0.99.3/Glide3/build-5/swlibs/fxmisc'
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.295 (%build)
    Bad exit status from /var/tmp/rpm-tmp.295 (%build)


Additional Information:
	
# rpm -q libtool
libtool-1.4-2
Comment 1 Mike A. Harris 2001-05-19 02:56:33 EDT
Jakub, any idea if this would be an X problem or libtool one?  I'm not
focussing on the rawhide stuff quite yet and X doesn't build in rawhide yet
anyway...

Just wondering wether libtool might be broken or not..
Comment 2 Will Newton 2001-05-27 13:32:14 EDT
This is fixed with XFree86-4.0.99.900.
Comment 3 Mike A. Harris 2001-06-01 01:13:59 EDT
Yep.  I am building the 90x series flawlessly now.
Just so you know - DRI doesn't work yet with our rawhide kernel.  Should soon
though.

Note You need to log in before you can comment on or make changes to this bug.