Bug 413521 - KDM times out trying to display the list of users
KDM times out trying to display the list of users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 01:28 EST by Jacek Piskozub
Modified: 2007-12-07 05:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 05:51:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Piskozub 2007-12-06 01:28:57 EST
Description of problem:

GDM times out when getting the list of users from an LDAP directory.

Version-Release number of selected component (if applicable):

gdm-2.20.1-5.fc8

How reproducible:

Almost always on my test machine (Pentium III 800, 100Mbps network link, about
300 accounts in LDAP)

Steps to Reproduce:
1.Boot
2.Wait for kdm to fail
  
Actual results:

X server starts but goes back to text console instead of showing the greeting
screen with user list.

Expected results:

KDM starts and displays the greeter with the list of users.

Additional info:

This is a slow 833Mhz computer which explains a lot but is no excuse for Fedora.

Setting ServerTimeout=30 in kdmrc solves the matter.

This bug is the KDE version of bug 371271.
Comment 1 Jacek Piskozub 2007-12-06 01:31:54 EST
The KDM version of the same problem has been reported as bug 413521.
Comment 2 Jacek Piskozub 2007-12-06 01:33:18 EST
One correction. I copied part of the content from the GDM bug. The version
number should be kdebase-3.5.8-5.fc8. Sorry.
Comment 3 Kevin Kofler 2007-12-06 01:38:09 EST
Try setting FaceSource=AdminOnly in kdmrc (instead of PreferUser).
Comment 4 Jacek Piskozub 2007-12-06 01:44:14 EST
Re: comment 3.

Why? I already gave the solution which is setting ServerTimeout=30 in kdmrc.

FaceSource=AdminOnly would deface (quite literally) my greeting screen, while
ServerTimeout=30 works as I expect it to work (that is showing the faces of my
users)  
Comment 5 Kevin Kofler 2007-12-06 01:50:06 EST
Because there was a previous bug report which pointed to user images as the 
source of the slowness. But it may be a different issue for you.
Comment 6 Jacek Piskozub 2007-12-06 02:06:54 EST
Well. Yes, I do use user images and I believe they make the X server start time
longer than the default time set in kdmrc on a slow computer.

However, I do not understand why killing this function (user faces) is deemed
the correct solution. In an ideal world the solution should be repairing the
problem, not killing the function.

I have two suggestions. Either the default ServerTimeout=15 should be changed or
a script should be added to increase the value on slow computers.

My problem is already fixed. I filed the report for the benefit of others who
may have the same problem but are not expert enough to identify and correct the
timeout problem.
Comment 7 Ngo Than 2007-12-07 05:51:35 EST
it's now fixed in kde-settings-3.5-36 and rawhide, with default 
ServerTimeout=30. It will be available in F8 update soon. 

Thanks

Note You need to log in before you can comment on or make changes to this bug.