Bug 41353 - Poweroff crashes just before it should power down
Poweroff crashes just before it should power down
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-19 09:09 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 16:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-19 09:09:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Hi,

When I select power off (in the gnome exit dialog), the powerdown proceeds
just as it did in RH 7.0 (with some additional lines). However, just after
it prints "stopping all MD-devices", it floods the screen with hexadecimal
numbers enclosed in brackets "[]" and then the computers halts. In the good
old days - RH 7.0 - it just printed "power down" and gracefully turned the
computer off. Now I have to manually switch it off.

What could be wrong? apmd? (I'm using a ordinary desktop btw)  init? Some
module in the kernel?

Best Regards,

Per Johansson

How reproducible:
Always

Steps to Reproduce:
1. Click on the log out icon in the gnome panel
2. Select shutdown (or whatever it's called in the english version)
3. Click OK

Actual Results:  It prints out a lot of hexadecimal numbers in bracket
paranteses.
I have to turn the computer off manually.

Expected Results:  It should turn the computer off.

Additional info:

It worked perfect in RedHat 7.0
Comment 1 Bernhard Rosenkraenzer 2001-05-20 06:08:33 EDT
Since I'm not seeing this on any of my machines, I assume it's a bug in your 
BIOS and older kernels had a workaround.

In any case, this looks like it happens when the kernel tries to power off the 
machine, reassigning.
Comment 2 Arjan van de Ven 2001-05-20 06:30:55 EDT
Can you try adding "apm=realmode" to the lilo prompt?
(type <ctrl key>-X on the graphical screen and type "linux apm=realmode")
Comment 3 Need Real Name 2001-05-20 08:50:52 EDT
Hi!

Thanks for the tip - it works a bit better now. I have now also added
append="amd=realmode" to lilo.conf.
After this workaround, it says "stopping all MD-devices" and then "Power down";
but after that, the computer just halts (since it's realmode it doesn't power
down). Reboot works OK though.

My computer is a Hyrican from Delix (which is now owned by RedHat!) and the BIOS
is from Award Software (which is now Phoenix?).  I can't find BIOS-upgrades for
Linuxusers and this machine has been running Linux from the very start. I don't
want to install Windows just for upgrading my BIOS. Does anyone know how to
upgrade the BIOS in Linux? I have never done such a thing in Linux. And where
can I find ROM-files???

Anyway, thank you very much! I feel a bit more comfortable now when it doesn't
flood the screen with strange numbers. If it could be to any help, the numbers
looks (looked) like this: [ <FFFF00000> ]

Best Regards,

Per Johansson
Comment 4 Need Real Name 2001-05-20 08:54:07 EDT
That should be "apm=realmode" of course...

Regards,

Per Johansson
Comment 5 Bill Nottingham 2001-05-21 14:39:04 EDT
Without the exact numbers, it's hard to make a suggestion. What's
the text next to 'EIP:'?
Comment 6 Arjan van de Ven 2001-05-21 15:10:30 EDT
notting: This is the bios oopsing.. Buggy bios :)
Comment 7 Need Real Name 2001-05-21 16:01:32 EDT
Hi!

Yup - it looks like the BIOS is the one to blame. I can't find anything in the
kernel that would produce that output.

The numbers were all different and just kept flooding the screen. I didn't se
any kind of text prior to the number flood. So after "stopping all md devices"
the output on the screen was simply
[ <52657821> ][ <fe40c239> ] ... And the list went on and on and on and on
and....

I couldn't see a "Kernel Panic" or anything like that. However - i did not see
the text "Power down", so obviously something happens just before that.

I have now found .bin files to my BIOS but they require Windows software for the
installation:-( My computer has been Linux from the very start and don't feel
like repartioning my hard drive just for that upgrade. Maybe there was some kind
of workaround in the old kernel?

Best Regards,

Per Johansson
Comment 8 Arjan van de Ven 2001-05-21 16:06:44 EDT
All bioses I've seen so far require a MSDOS program to flash it.
FreeDos on a bootfloppy does that just fine ;)
Comment 9 Arjan van de Ven 2001-06-06 09:42:12 EDT
I've made apm=realmode the default for your bios; a kernel with this should
appear in rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.