Bug 413621 - Fedora 8 hangs!!!
Fedora 8 hangs!!!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 04:08 EST by Sudipta Dey
Modified: 2007-12-17 10:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 10:32:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sudipta Dey 2007-12-06 04:08:17 EST
Description of problem:
I have installed Fedora 8 x86_64 on my dual boot laptop HP pavilion dv9500z (AMD
Turion 64 X2 TL-60 2.00 GHz, 4 GB RAM, 128MB Nvidia 8400M GS). Running graphics
mode (init 5)

My wireless card(BroadCom 4321AG) was not detected automatically, so I installed
my windows driver using ndiswrapper. It got installed properly and the device
became accesible. After setting up wlan0 I tried to activate the interface thru
"Network Configuration". The whole KDE GUI became unresponsive. I tried to get
to console but couldn't, system hang!!!
Second time I tried running Kopete. When I tried quitting the application the
KDE GUI hanged again
Third time happened when I tried restarting Network service after activating my
wireless interface
Every time I was forced to do a hard reboot, screwing up my filesystem ...
forcing check and fix
Then the kernel started dumping after every reboot after login at desktop

Version-Release number of selected component (if applicable):
kernel: 2.6.23.8-63.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
System hang

Expected results:
System should recover from any malfunction

Additional info:
Comment 1 Dan Williams 2007-12-06 05:48:19 EST
Sounds like ndiswrapper is causing a kernel panic that's bringing down your box.
 I'd suggest not using ndiswrapper, but...

John; does bcm43 support the 4321 yet?
Comment 2 John W. Linville 2007-12-06 09:19:05 EST
I think so, but not 100% sure.  What is the output of 'lspci -n'?

I can't support an ndiswrapper kernel issue.  Would you like to explore 
getting b43 working?
Comment 3 Sudipta Dey 2007-12-06 17:33:55 EST
Well I would like to add that before kernel panic the HAL daemon was crashing
... It might be due to ndiswrapper. So I had to reinstall my system.

I will explore b43 and and see if I can make it work for my wireless card...
Comment 4 Sudipta Dey 2007-12-06 17:52:46 EST
I update the existing packages. Noticed 'ssb' driver is installed for my
wireless card. But it doesn't work.
Ndiswrapper is working for me. Wireless setup is very easy using ndiswrapper.
Just don't want see it breaking HAL daemon again. 
Most linux forums advised to use ndiswrapper for BroadCom 4321AG
802.11a/b/g/draft-n cards. Where can I find the updated bcm43/bcm43xx drivers?
Comment 5 John W. Linville 2007-12-06 18:04:34 EST
Is either the "b43" or "b43legacy" module loaded?

Did you install the requisite firmware?  You might want to try the 'noarch' 
packages here:

   http://fedora.tuxdriver.com/rfc/

They will download and install the appropriate firmware to the correct place, 
given that you have a working Internet connect.
Comment 6 Sudipta Dey 2007-12-15 00:38:47 EST
I tried the b43 drivers. I doesn't work for my wireless card. I don't see wlan0.
I am still using ndiswrapper to connect to 802.11 n network. It working fine now.

Note You need to log in before you can comment on or make changes to this bug.