Bug 413641 - Problem with iwl3945: Microcode SW error detected. Restarting 0x82000008
Problem with iwl3945: Microcode SW error detected. Restarting 0x82000008
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 04:34 EST by Sven Oehme
Modified: 2011-04-25 13:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 699447 (view as bug list)
Environment:
Last Closed: 2008-02-06 09:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sven Oehme 2007-12-06 04:34:06 EST
Description of problem:

any Kernel after 2.6.23.1-49.fc8 i tried is not able to connect to any Wireless
Network. any time i try to connect to a network i see the following errors in
dmesg : 

iwl3945: Microcode SW error detected.  Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x000B ser 0x0000004B
iwl3945: Error setting new configuration (-5).
iwl3945: Can't stop Rx DMA.
iwl3945: Microcode SW error detected.  Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x0000 ser 0x0000004B
iwl3945: Error setting new configuration (-5).
iwl3945: Can't stop Rx DMA.
wlan0: failed to set channel 44 (5220 MHz) for scan
wlan0: failed to set channel 46 (5230 MHz) for scan
wlan0: failed to set channel 48 (5240 MHz) for scan
wlan0: failed to set channel 52 (5260 MHz) for scan
wlan0: failed to set channel 56 (5280 MHz) for scan
wlan0: failed to set channel 60 (5300 MHz) for scan
wlan0: failed to set channel 64 (5320 MHz) for scan
wlan0: failed to set channel 100 (5500 MHz) for scan
wlan0: failed to set channel 104 (5520 MHz) for scan
wlan0: failed to set channel 108 (5540 MHz) for scan
wlan0: failed to set channel 112 (5560 MHz) for scan
wlan0: failed to set channel 116 (5580 MHz) for scan
wlan0: failed to set channel 120 (5600 MHz) for scan
wlan0: failed to set channel 124 (5620 MHz) for scan
wlan0: failed to set channel 128 (5640 MHz) for scan
wlan0: failed to set channel 132 (5660 MHz) for scan
wlan0: failed to set channel 136 (5680 MHz) for scan
wlan0: failed to set channel 140 (5700 MHz) for scan
wlan0: failed to restore operational channel after scan
virbr0: no IPv6 routers present
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
iwl3945: Microcode SW error detected.  Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x000B ser 0x0000004B
iwl3945: Error setting new configuration (-5).
iwl3945: Can't stop Rx DMA.

Version-Release number of selected component (if applicable):

last working : 
iwl3945-firmware-2.14.1.5-2
kernel-2.6.23.1-49.fc8

i tried any kernel after this level and all fail, even kernels from kojo .. 
the latest i tested is kernel-2.6.23.9-80.fc8 still the same errors ..

How reproducible:

install any kernel after kernel-2.6.23.1-49.fc8 on 64 bit Laptop and try to
connect to a network 

Steps to Reproduce:
1. boot up
2. iwlist wlan0 scan
3. iwconfig ...
  
Actual results:

system freezes for a short time (3-4 sec) then continues .. but no network
connected 

Expected results:

i should get an ip from my network ..

Additional info:

lspci  |grep -i wire
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
[root@oehmeslxtp ~]#               

iwconfig  wlan0
wlan0     IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=15 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[root@oehmeslxtp ~]#
Comment 1 Neil Viglieno 2007-12-21 08:18:48 EST
Are you using the disable_hw_scan=1 option for the iwl3945? 

I was, and I started getting the same error on my T60 with kernels after
2.6.23.1-49.fc8

After removing the disable_hw_scan=1 option, the error has gone away, and I'm
connecting error free with kernel-2.6.23.9-85.fc8.

Comment 2 Matthias Saou 2008-02-03 07:15:14 EST
Reassigning to the kernel since I doubt this is firmware package related...

Sven : Can you please confirm if this problem persists, or if an F-8 update has
fixed it since?
Comment 3 Sven Oehme 2008-02-05 15:17:36 EST
i updated to the latest fc9 kernel from kojo , that fixed my problem .. 
Comment 4 Pablo Iranzo Gómez 2011-04-04 14:20:54 EDT
[18192.609271] iwl3945 0000:03:00.0: Microcode SW error detected. Restarting 0x82000008.

 
This happens on my F15 machine (lenovo x60) with kernel 2.6.38.2-9.fc15.i686 it can connect and works fine, but those errors appear on dmesg every few minutes (110 times since 16:40:59 until 20:18.58)
Comment 5 Pablo Iranzo Gómez 2011-04-04 14:22:08 EDT
Full message of last one is:

[18552.652421] iwl3945 0000:03:00.0: Microcode SW error detected. Restarting 0x82000008.
[18552.652431] iwl3945 0000:03:00.0: Loaded firmware version: 15.32.2.9
[18552.652468] iwl3945 0000:03:00.0: Start IWL Error Log Dump:
[18552.652474] iwl3945 0000:03:00.0: Status: 0x0002A2E4, count: 1
[18552.652480] iwl3945 0000:03:00.0: Desc       Time       asrtPC  blink2 ilink1  nmiPC   Line
[18552.652719] iwl3945 0000:03:00.0: SYSASSERT     (0x5) 1725058024 0x008B6 0x13756 0x00320 0x00000 764
[18552.652721] 
[18552.652857] iwl3945 0000:03:00.0: Start IWL Event Log Dump: display last 20 count
[18552.652898] iwl3945 0000:03:00.0: 1725057083	0x00000000	0201
[18552.652921] iwl3945 0000:03:00.0: 1725057093	0x0000001c	0206
[18552.652944] iwl3945 0000:03:00.0: 1725057095	0x00400001	0204
[18552.652968] iwl3945 0000:03:00.0: 1725057100	0x00400001	0219
[18552.652991] iwl3945 0000:03:00.0: 1725057101	0x00020041	0211
[18552.653014] iwl3945 0000:03:00.0: 1725057106	0x00000000	0212
[18552.653037] iwl3945 0000:03:00.0: 1725057437	0x00000000	0215
[18552.653060] iwl3945 0000:03:00.0: 1725057511	0x00400008	0220
[18552.653083] iwl3945 0000:03:00.0: 1725057526	0x00000000	0301
[18552.653106] iwl3945 0000:03:00.0: 1725057795	0x000000d4	0303
[18552.653129] iwl3945 0000:03:00.0: 1725057969	0x44420080	0401
[18552.653152] iwl3945 0000:03:00.0: 1725057983	0x00000016	0452
[18552.653175] iwl3945 0000:03:00.0: 1725057988	0x00113b6e	0450
[18552.653198] iwl3945 0000:03:00.0: 1725057993	0x00113b6e	0450
[18552.653221] iwl3945 0000:03:00.0: 1725057999	0x00113b6e	0450
[18552.653244] iwl3945 0000:03:00.0: 1725058003	0x00113b6e	0450
[18552.653267] iwl3945 0000:03:00.0: 1725058009	0x00123b6e	0450
[18552.653290] iwl3945 0000:03:00.0: 1725058014	0x00123b6e	0450
[18552.653313] iwl3945 0000:03:00.0: 1725058019	0x00123b6e	0450
[18552.653336] iwl3945 0000:03:00.0: 1725058025	0x00000100	0125
[18552.653358] iwl3945 0000:03:00.0: Error Reply type 0x000002FC cmd REPLY_SCAN_CMD (0x80) seq 0x4442 ser 0x00340000
[18552.657770] iwl3945 0000:03:00.0: Can't stop Rx DMA.
Comment 6 Oded Arbel 2011-04-25 13:17:22 EDT
this problem recurs in Fedora 15 and may be a regression, but this ticket is closed so I opened a new bug #699447 for this.

Note You need to log in before you can comment on or make changes to this bug.