Bug 413751 - segfault when starting rhmd if no write permission for db files
segfault when starting rhmd if no write permission for db files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Gordon Sim
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 06:10 EST by Gordon Sim
Modified: 2009-05-07 16:09 EDT (History)
0 users

See Also:
Fixed In Version: qpidd-0.2-24.el5, qpidc-0.2-24.el5, and rhm-0.2-18.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 11:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2007-12-06 06:10:26 EST
To reproduce:

simple case: 
    start broker as root, using default location for storage (/var/rhm)
    shutdown, change to a 'normal' user and try to restart; get segfault

or:
    create a directory for use as store location, start the broker then shutdown
    chmod -w for all the files in <store-location>/rhm/dat/
    try and restart; get segfault
Comment 1 Gordon Sim 2007-12-06 08:11:38 EST
Caused by aborting a transaction (around recovery) that wasn't actually started.
Fixed in rev 1432 of the rhmessaging repo.
Comment 2 Gordon Sim 2007-12-07 09:44:05 EST
Fixed in build.330 on qpid-test, build.41 on qpid-test4.
Comment 3 Mike Bonnet 2008-02-29 11:46:48 EST
Fixed in qpidd-0.2-24.el5, qpidc-0.2-24.el5, and rhm-0.2-18.el5

Note You need to log in before you can comment on or make changes to this bug.