Bug 413881 - Fontconfig conflict on x86_64 sat
Summary: Fontconfig conflict on x86_64 sat
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer   
(Show other bugs)
Version: 510
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Justin Sherrill
URL:
Whiteboard:
Keywords:
: 426165 (view as bug list)
Depends On:
Blocks: 248641
TreeView+ depends on / blocked
 
Reported: 2007-12-06 13:17 UTC by Miroslav Suchý
Modified: 2008-04-02 20:55 UTC (History)
1 user (show)

Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:55:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miroslav Suchý 2007-12-06 13:17:14 UTC
Description of problem:
Oracle-server depend on package Fontconfig. Since we have 32 bit Oracle-server
on x86_64 ISO, it should have Fontconfig.i386, but @base have already fontconfig
and it is x86_64. This two package conflicts.

We have to either somehow resolve this conflicts, or compile oracle-server as
x86_64. I think the second is the right way.

Version-Release number of selected component (if applicable):
510-64bit

How reproducible:
done once

Steps to Reproduce:
1. install x86_64 iso

Comment 1 Jan Pazdziora 2007-12-19 14:15:07 UTC
*** Bug 426165 has been marked as a duplicate of this bug. ***

Comment 2 Michael Mráka 2007-12-21 11:15:50 UTC
fontconfig.i386 is required by xorg-x11-depreciated-libs.i386
xorg-x11-depreciated-libs.i386 is required by openmotif21.i386
openmotif21.i386 is required by oracle-server-920.i386

So we need take out unnecessary libraries with openmotif requirement (from 
oracle-server-920 package).

Comment 3 Michael Mráka 2007-12-21 11:34:31 UTC
Fixed in oracle-server-920-9.2.0.8.0-6.i386.rpm

Sending        misc/oracle-server/9.2.0/oracle-server.spec
Transmitting file data ..
Committed revision 135096.


Testcase:
1. install x86_64 iso
2. rpm -q oracle-server-920 fontconfig.i386 openmotif21 xorg-x11-depreciated-
libs

expected results:
1. succesful installation
2.
oracle-server-920-9.2.0.8.0-6
package openmotif21 is not installed
package xorg-x11-depreciated-libs is not installed



Comment 4 Justin Sherrill 2008-01-04 16:12:30 UTC
works for me on build -32

Comment 5 Mike McCune 2008-03-26 01:14:51 UTC
verified since we have a bunch of x86_64 installs in stage that worked fine.

Comment 6 Brandon Perkins 2008-04-02 20:52:30 UTC
64Bit-Satellite/Proxy on x86_64 RHEL for 5.1 Sat GA so Closed for Current Release.

Comment 7 Brandon Perkins 2008-04-02 20:55:31 UTC
64Bit-Satellite/Proxy on x86_64 RHEL for 5.1 Sat GA so Closed for Current Release.


Note You need to log in before you can comment on or make changes to this bug.