Bug 4139 - "invalid ICMP errors to a broadcast" console messages
"invalid ICMP errors to a broadcast" console messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-21 12:45 EDT by dsummers
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dsummers 1999-07-21 12:45:03 EDT
This seems to be more a problem with 2.2 kernels in general,
but I thought I'd bring it to your attention. In certain
network environments, the 2.2 kernel reports quite few
invalid error messages from routing devices. Since ICMP is
built into the kernel, the messages pop to the console,
which is a mild to ehavy annoyance, depending on what you
are trying to do on the console.

echo "3 5 1 7" into /proc/sys/kernel/printk removes the
console logging problem, but IMHO this is something that
should be looked at as a deeper minor issue to contend with.

------- Additional Comments From   07/22/99 11:36 -------
A fix found is to set a switch in /proc/sys/net/ipv4 to 1:
    icmp_ignore_bogus_error_responses
The command to do this would be:
    echo "1" > icmp_ignore_bogus_error_responses

Note You need to log in before you can comment on or make changes to this bug.