Bug 414341 - "iptables stop" kills libvirt port forwarding
Summary: "iptables stop" kills libvirt port forwarding
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: iptables   
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-06 16:41 UTC by Bastien Nocera
Modified: 2007-12-11 15:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 15:03:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2007-12-06 16:41:43 UTC
1. Start host with restrictive firewall
2. Startup a virtual machine on that machine
3. Realise the firewall is blocking access to the physical host
4. run "/etc/init.d/iptables stop"

iptables has wiped the bridge settings from libvirtd

Comment 1 Daniel Berrange 2007-12-06 16:54:27 UTC
It did exactly what you asked it todo - it removed all iptables settings :-)

You can restore rules by sending libvirtd SIGHUP, or 'service libvirtd reload'


Comment 2 Bastien Nocera 2007-12-06 18:11:53 UTC
I figured that. But what about UI apps that rely on simply starting/stopping
iptables once /etc/sysconfig/iptables?

I'm thinking system-config-firewall in particular.

Comment 3 Thomas Woerner 2007-12-11 15:03:18 UTC
I am sorry, but if you stop iptables, all the chains and rules are dropped. This
is intended behavior. s-c-fw does not know about libvirtd, same for all other
firewall configuration tools available.

Closing as "NOT A BUG".


Note You need to log in before you can comment on or make changes to this bug.