Bug 41435 - up2date and rhn_register problems
Summary: up2date and rhn_register problems
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-20 13:43 UTC by Need Real Name
Modified: 2015-01-07 23:45 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-09-17 16:23:57 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-05-20 13:43:06 UTC
Description of Problem:
when running rhn_register i get this output:
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade", line 28 __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/register/gui.py", line 417, in 
onProfilePagePrepare 
    hardware.read_network()
  File "usr/share/rhn/register/hardware.py", line261, in read_network
    netdict['ipaddr'] = gethostbyname(gethostname())
socket.error: host not found

ive tried twice whith the same result
then i tried up2date, and got errormessage about Software Manager 
funktionality not being enabled, this has now happend 3 times then i did 
as i vas told i clicked on my profile and wanted it to become activated 
but nothing happened exept for ending up here

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Cristian Gafton 2001-08-10 20:57:14 UTC
Assigned to the owner of component

Comment 2 softrat 2001-09-17 00:12:48 UTC
It's September and this bug isn't fixed yet!



Comment 3 Adrian Likins 2001-09-17 16:23:52 UTC
can you attach a copy of /etc/hosts?

The only time I've seen this is when the machine advertised a hostname
that didnt map to any ip address it knows about.

Comment 4 Adrian Likins 2002-05-15 20:57:12 UTC
since theres no activity on this, and the only way that
error can occur is with an invalid hostname, I'm closing
this bug.

Current versions of the code will just assume the ip
for the default hostname is 127.0.0.1, since it's impossible
to tell otherwise with an invalid hostname.


Note You need to log in before you can comment on or make changes to this bug.