Bug 414531 - RHEL5 multipath configuration issue with StorageTek D280 array
RHEL5 multipath configuration issue with StorageTek D280 array
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Ben Marzinski
Corey Marthaler
:
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2007-12-06 14:12 EST by Issue Tracker
Modified: 2010-10-22 17:02 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-11 18:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport (703.38 KB, application/x-bzip2)
2007-12-06 14:16 EST, David Milburn
no flags Details
multipath_v3 (5.20 KB, text/plain)
2007-12-06 14:18 EST, David Milburn
no flags Details
multipath_ll (493 bytes, text/plain)
2007-12-06 14:19 EST, David Milburn
no flags Details

  None (edit)
Description Issue Tracker 2007-12-06 14:12:17 EST
Escalated to Bugzilla from IssueTracker
Comment 3 Issue Tracker 2007-12-06 14:12:22 EST
How reproducible:
-----------------
GWL wishes to configure the Storagetek D280 in active-passive mode, with
1 or more LUNs, dual-pathed (multiple single-port or dual-port Qlogic
HBA's).


GWL can reproduce on every reboot.  As described by GWL, when the RHEL 5
system boots, qla driver loads, detects the paths and LUNs.  Apparently,
as multipath driver loads, the primary path fails-over to secondary
path, but will not fail-back.

Customer reports that manual failover procedures work but on each and
every system boot, they *must* manually fail-back to the primary path.


Steps to Reproduce:
-------------------
I do not have access to the hardware at this time.  GWL used
the /etc/multipath.conf file recommended by Benjamin Marzinski & Tom
Coughlan as well as added entries to /etc/lvm.conf in an attempt to
prevent path probing.

Actual results:
---------------
As indicated in /var/log/messages, the unintended path failover occurs
on system boot after adding recommended edits to lvm.conf &
multipath.conf.

Expected results:
-----------------
Presume customer should expect the primary paths *not* to fail on system
boot and should *not* need to manually fail-back paths on every boot.



This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 141103
Comment 4 Issue Tracker 2007-12-06 14:12:23 EST
Customer has given an update to his case.
-----------

	using the following configuration I can now failover and back
successfully.  Also when I run pvdisplay, vgdisplay, or lvdisplay the
paths to stay on preferred path.

output of multipathd -k show config:

multipathd> show config
defaults {
       failback immediate
       user_friendly_names yes
}
blacklist {
       devnode ^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*
       devnode ^hd[a-z]
       devnode ^sda
       devnode ^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*
       devnode ^hd[a-z]
       device {
               vendor DGC
               product LUNZ
       }
       device {
               vendor IBM
               product S/390.*
       }
}
blacklist_exceptions {
}
devices {
       device {
               vendor STK
               product OPENstorage D280
               path_grouping_policy group_by_prio
               path_checker tur
               prio_callout /sbin/mpath_prio_tpc /dev/%n
       }
       device {
               vendor APPLE*
               product Xserve RAID
               path_grouping_policy multibus
       }
       device {
               vendor 3PARdata
               product VV
               path_grouping_policy multibus
       }
       device {
               vendor DEC
               product HSG80
               path_grouping_policy group_by_serial
               path_checker hp_sw
               hardware_handler 1 hp_sw
       }
       device {
               vendor (COMPAQ|HP)
               product MSA1.*
               path_grouping_policy multibus
               path_checker hp_sw
               hardware_handler 1 hp_sw
       }
       device {
               vendor (COMPAQ|HP)
               product HSV(1|2).*
               path_grouping_policy group_by_prio
               path_checker tur
               prio_callout /sbin/mpath_prio_alua %n
               no_path_retry 60
               rr_min_io 100
       }
       device {
               vendor HP
               product A6189A
               path_grouping_policy multibus
       }
       device {
               vendor DDN
               product SAN DataDirector
               path_grouping_policy multibus
       }
       device {
               vendor EMC
               product SYMMETRIX
               path_grouping_policy multibus
               getuid_callout /sbin/scsi_id -g -u -ppre-spc3-83 -s
/block/%n
       }
       device {
               vendor DGC
               product .*
               product_blacklist LUNZ
               path_grouping_policy group_by_prio
               path_checker emc_clariion
               features 1 queue_if_no_path
               hardware_handler 1 emc
               prio_callout /sbin/mpath_prio_emc /dev/%n
               no_path_retry 60
       }
       device {
               vendor FSC
               product CentricStor
               path_grouping_policy group_by_serial
       }
       device {
               vendor (HITACHI|HP)
               product OPEN-.*
               path_grouping_policy multibus
               path_checker tur
               rr_min_io 100
       }
       device {
               vendor HITACHI
               product DF.*
               path_grouping_policy group_by_prio
               prio_callout mpath_prio_hds_modular %d
       }
       device {
               vendor IBM
               product ProFibre 4000R
               path_grouping_policy multibus
       }
       device {
               vendor IBM
               product 1742
               path_grouping_policy group_by_prio
               path_checker tur
               prio_callout /sbin/mpath_prio_tpc /dev/%n
       }
       device {
               vendor IBM
               product 3526
               path_grouping_policy group_by_prio
               path_checker tur
               prio_callout /sbin/mpath_prio_tpc /dev/%n
       }
       device {
               vendor IBM
               product 3542
               path_grouping_policy group_by_serial
               path_checker tur
       }
       device {
               vendor IBM
               product 2105(800|F20)
               path_grouping_policy group_by_serial
               path_checker tur
               features 1 queue_if_no_path
       }
       device {
               vendor IBM
               product 1750500
               path_grouping_policy group_by_prio
               path_checker tur
               features 1 queue_if_no_path
               prio_callout /sbin/mpath_prio_alua /dev/%n
       }
       device {
               vendor IBM
               product 2107900
               path_grouping_policy multibus
               path_checker tur
               features 1 queue_if_no_path
       }
       device {
               vendor IBM
               product 2145
               path_grouping_policy group_by_prio
               path_checker tur
               features 1 queue_if_no_path
               prio_callout /sbin/mpath_prio_alua /dev/%n
       }
       device {
               vendor IBM
               product S/390 DASD ECKD
               product_blacklist S/390.*
               path_grouping_policy multibus
               getuid_callout /sbin/dasd_id /dev/%n
               path_checker directio
       }
       device {
               vendor NETAPP
               product LUN.*
               path_grouping_policy group_by_prio
               features 1 queue_if_no_path
               prio_callout /sbin/mpath_prio_netapp /dev/%n
               rr_min_io 128
       }
       device {
               vendor IBM
               product Nseries.*
               path_grouping_policy group_by_prio
               features 1 queue_if_no_path
               prio_callout /sbin/mpath_prio_netapp /dev/%n
               rr_min_io 128
       }
       device {
               vendor Pillar
               product Axiom 500
               path_grouping_policy group_by_prio
               path_checker tur
               prio_callout /sbin/mpath_prio_alua %d
       }
       device {
               vendor SGI
               product TP9[13]00
               path_grouping_policy multibus
       }
       device {
               vendor SGI
               product TP9[45]00
               path_grouping_policy group_by_prio
               path_checker tur
               prio_callout /sbin/mpath_prio_tpc /dev/%n
       }
       device {
               vendor SUN
               product (StorEdge 3510|T4)
               path_grouping_policy multibus
       }
       device {
               vendor DELL
               product MD3000
               path_grouping_policy group_by_prio
               hardware_handler 1 rdac
               prio_callout /sbin/mpath_prio_tpc /dev/%n
               failback manual
       }
       device {
               vendor GNBD
               product GNBD
               path_grouping_policy multibus
               getuid_callout /sbin/gnbd_import -q -U /block/%n
               path_checker directio
       }
}
multipaths {

-------------------------------------------

list below is /etc/multipath.conf

defaults {
      udev_dir                /dev
      failback                immediate
      user_friendly_names     yes
}

blacklist {
       devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
       devnode "^hd[a-z]"
       devnode "^sda"
}

devices {
      device {
#               vendor                  "IBM"
#               product                 "1742"
               vendor                  "STK"
               product                 "OPENstorage D280"
              getuid_callout          "/sbin/scsi_id -g -u -s
/block/%n"
              prio_callout            "/sbin/mpath_prio_tpc /dev/%n"
              features                "0"
              hardware_handler        "0"
              path_grouping_policy    group_by_prio
              failback                immediate
              rr_weight               uniform
              rr_min_io               1000
              path_checker            tur
      }
}

I'm going to continue to test and update this ticket with results. 


This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 141103
Comment 6 David Milburn 2007-12-06 14:16:52 EST
Created attachment 280101 [details]
sysreport
Comment 7 David Milburn 2007-12-06 14:18:44 EST
Created attachment 280111 [details]
multipath_v3
Comment 8 David Milburn 2007-12-06 14:19:20 EST
Created attachment 280121 [details]
multipath_ll
Comment 9 Ben Marzinski 2007-12-06 17:32:22 EST
I'm glad that it it working now.

The only thing it don't understand is this; In an earlier email I received about
this problem, I was told that it was happening with a completely empty
multipath.conf file.  It turns out that the StorageTek D280 is autoconfigured
(having never used one, I didn't know what the vendor/product was, and I missed
it when checking through the default configuration).  In fact, the
autoconfiguration is the same as the configuration which currently works for
you. Do you actually see this problem with an empty /etc/multipath.conf?  It
should configure the device exactly like you have it now.

Can you please try removing the devices section from your /etc/multipath.conf,
and verify that everything is configured the same, and that paths failback
correctly. If it doesn't work, please let me know.
Comment 11 RHEL Product and Program Management 2008-06-02 16:26:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.