Bug 414831 - Broadcom Driver bnx2 causes panic under high network load
Broadcom Driver bnx2 causes panic under high network load
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Andy Gospodarek
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 15:54 EST by Jeff Bearer
Modified: 2014-06-29 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 11:18:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bearer 2007-12-06 15:54:03 EST
Description of problem:

There is a bug in the bnx2 driver that causes a kernel panic when the TX buffer
gets full.

http://git.kernel.org/?p=linux/kernel/git/davem/net-2.6.git;a=commit;h=faac9c4b753f420c02bdce0785d2657087830a12

It was fixed in version 1.5.2 of the module.  Centos 5.0 is using 1.4.44-1. 
1.5.2 was released about a year ago according to the developer.

Version-Release number of selected component (if applicable):


How reproducible:

Very easy under Xen, somewhat easy not under xen.


Steps to Reproduce:
1. mount server:/share /mnt
2. cd /mnt
3. cat file1_1gb file2_1gb > file3

Actual results:

with xen it crashes 50% of the time or more, without xen it crashes 5-50% of the
time.

Expected results:


Additional info:

RHEL 5.1 has 1.5.11 which has the bug fixed, but the problem is pretty serious
in my work environment and it should probably be backported to all supported
RHEL versions.
Comment 1 Jeff Bearer 2007-12-06 15:59:35 EST
I intended to say RHEL 5.0 is using 1.4.44-1,   not Centos.
Comment 2 Andy Gospodarek 2007-12-13 11:18:54 EST
Have you tried a 5.1 kernel?  (Maybe not if using CentOS since they haven't
rebuilt everything yet).

Feel free to try my test kernels here if you like, but this issue was resolved
quite a while ago and appears in any kernel version after 2.6.18-28.el5.

My test kernels are here:

http://people.redhat.com/agospoda/#rhel5

Please re-open if an updated kernel does not resolve this and please report any
issues you find while running my test kernels directly to me.  The more testing
the better!


Note You need to log in before you can comment on or make changes to this bug.