This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 414961 - Breakpoints set in pydev perspective are ignored during debugging
Breakpoints set in pydev perspective are ignored during debugging
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse-pydev (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 17:30 EST by Jesse Keating
Modified: 2013-01-09 21:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 16:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-12-06 17:30:13 EST
I set a number of breakpoints in my sources in the pydev perspective.  But when
trying to debug they were completely ignored.  This was obviously confusing.

However breakpoints I set while in the debug perspective were seen.
Comment 1 Jeff Johnston 2008-02-12 14:44:48 EST
Please retry with eclipse-pydev-1.3.12-1.fc8 which has updated the eclipse-pydev
release and contains a number of fixes.  The simple test below works for me:

--- simplestModule.py ---
def f(): pass
--- end simplestModule.py ---

--- simpleImport.py ---
import simplestModule as sm
sm.f()
--- end simpleImport.py ---

I set a breakpoint at the sm.f() line in simpleImport.py in the pydev editor.  I
debug with simpleImport.py as main module and I get my breakpoint.  I am then
able to step into simplestModule.py.  I do run into an error after stepping past
the last line into termination, but that is a separate problem.

If you have another scenario that is not working, please provide.
Comment 2 Bug Zapper 2008-05-14 00:06:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Alexander Kurtakov 2008-11-06 16:33:59 EST
No response for more then 6 months from the reporter. Pydev is now at version 1.3.24 which has many debugging improvements to the version Jeff asked to test.
Closing.
Please reopen if there is still problem.

Note You need to log in before you can comment on or make changes to this bug.