Bug 415071 - gdm does not grant perms to common devs for legged user
Summary: gdm does not grant perms to common devs for legged user
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-06 23:45 UTC by Frantisek Hanzlik
Modified: 2013-03-06 03:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 02:18:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frantisek Hanzlik 2007-12-06 23:45:35 UTC
Description of problem:
It seems as gdm (f8 testing version) not set proper ACLs for logged user
to misc /dev things (audio devs, removable devices, and maybe others)

Version-Release number of selected component (if applicable):
gdm-2.20.2-2.fc8.i386 from 3-Dec-2007

How reproducible:
For me always: when using gdm (no matter wher for KDE or GNOME session),
then audio control isn't accessible, DVD's aren't playable etc.
Modes of relevant special files are usually 660 or 640, with ACL
granting additional permissions for gdm, but not for just logged user.
And he, a wretch, cann't access and manage those devices.
Maybe hald daemon is also unhappy, in /var/log/messages are some
segfault slights.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2007-12-07 03:32:12 UTC
Hi,

hal sets these permissions in response to consolekit events, not gdm.  Since you
mentioned hal segfaults, i'm going to assume the problem is in hal not consolekit.

Reassigning.

Comment 2 Bug Zapper 2008-05-14 04:06:54 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Scott Glaser 2009-04-07 23:52:39 UTC
Are you still running Fedora 9, or have you upgraded to 10 or Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Frantisek Hanzlik 2009-05-04 08:10:07 UTC
Last (unpatched) F9 box with this behavior I was upgrade to Rawhide Beta four weeks ago. On several other patched F9 PCs this bug no more exist, I cannot precisely tell when it go avay.
On F10 nor Rawhide (up to 1-May-2009) I not met with this problem, then probably this bug isn't now meaningful.

Comment 5 Scott Glaser 2009-05-18 02:18:02 UTC
Frantisek,

Based on your last comment I am going to close this bug.

Closed ERRATA

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.