Bug 415091 - hald-addon-storage polling every 2 seconds should not cause 20 wakeups / second from libata
hald-addon-storage polling every 2 seconds should not cause 20 wakeups / seco...
Status: CLOSED DUPLICATE of bug 204969
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 19:32 EST by Oliver Henshaw
Modified: 2013-03-05 22:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 11:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace -tt of both hald-addon-storage processes with empty drives (4.78 KB, text/plain)
2007-12-06 19:46 EST, Oliver Henshaw
no flags Details
strace -tt of both hald-addon-storage processes with locked drives (6.01 KB, text/plain)
2007-12-06 19:47 EST, Oliver Henshaw
no flags Details

  None (edit)
Description Oliver Henshaw 2007-12-06 19:32:51 EST
Description of problem:
Powertop reveals 20 interrupts from libata per second when there is no hard disk
activity. It may be relevant that there are two (ide) optical drives on this
system. I understand that hald-addon-storage polls the cd/dvd drives every
couple of seconds, but this still seems like too many.

Some data points:
* Killing hald-addon-storage from powertop causes libata wakeups to drop to
near-zero (0.2/second over 15 seconds).
* Inserting an audio cd in each drive and then quitting kscd so that both drives
are locked results in only around 2 interrupts/second from libata.
* As an aside, this is better than kernel 2.6.23.1-49 which had typically 40
wakeups/second and around 3 wakeups / second even after killing hald-addon-storage.

Based on the attached strace, below, I suspect that hald-addon-storage is
polling the two optical drives in alternate seconds. Something like bug #204969
comment #1 may help synchronize the times that the two optical drives are
polled. This would still leave the problem of hald-addon-storage causing 20
wakeups every time it polls is - whether this is due to some inefficiency or
can't be helped, I don't know.

Version-Release number of selected component (if applicable):
hal-0.5.10-1
kernel-2.6.23.8-63
Comment 1 Oliver Henshaw 2007-12-06 19:46:13 EST
Created attachment 280311 [details]
strace -tt of both hald-addon-storage processes with empty drives

The strace output I've attached seems to actually have both drives being polled
in the same second, unlike an earlier test I did not record, and contrary to my
claim above.  Still, there may be a way to better synchronize the polling or
make it more efficient in terms of interrupts.
Comment 2 Oliver Henshaw 2007-12-06 19:47:10 EST
Created attachment 280331 [details]
 strace -tt of both hald-addon-storage processes with locked drives
Comment 3 David Zeuthen 2007-12-07 11:09:42 EST

*** This bug has been marked as a duplicate of 204969 ***

Note You need to log in before you can comment on or make changes to this bug.