Bug 4152 - --prefix does not work when installing source rpm
--prefix does not work when installing source rpm
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-21 21:49 EDT by kestes
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-22 09:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kestes 1999-07-21 21:49:38 EDT
I tried running this command

rpm -U --prefix /data1/builds/1 \
htdocs-redirect-emc-2.48-2.src.rpm


I have a topdir setup in /data1/builds/1 and the
files did not go into /data1/builds/1/SOURCES and
/data1/builds1/SPECS


I use RPM version 2.5.6 so this may be fixed in your sources
already.
Comment 1 Jeff Johnson 1999-07-22 09:59:59 EDT
The --prefix option supplies a new leading path for a tag in a binary
rpm containing that contains the old leading path and absolute
path names. Since src.rpm's contain relative not absolute paths
and do not contain a prefix tag at all it's unclear whether the
effort involved in implementing --prefix is worth the effort.

Meanwhile, try
	rpm --define '_topdir	/data1/builds/1' -U ...
which should have the desired effect.

Note You need to log in before you can comment on or make changes to this bug.