Bug 415231 - X zoom (ctrl+alt+plus/minus) keys and xvidtune don't work with radeon driver
X zoom (ctrl+alt+plus/minus) keys and xvidtune don't work with radeon driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 00:07 EST by Douglas Wooster
Modified: 2009-01-09 02:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:30:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from FC7, where X zoom keys and xvidtune work correctly (78.68 KB, text/plain)
2007-12-07 00:11 EST, Douglas Wooster
no flags Details
xorg.conf which worked on FC7 (711 bytes, text/plain)
2007-12-07 00:15 EST, Douglas Wooster
no flags Details
latest FC8 xorg.conf (1.22 KB, text/plain)
2007-12-07 00:17 EST, Douglas Wooster
no flags Details
FC8 log, after trying zoom keys, xvidtune, and finally xrandr (161.60 KB, text/plain)
2007-12-07 00:20 EST, Douglas Wooster
no flags Details

  None (edit)
Description Douglas Wooster 2007-12-07 00:07:13 EST
Description of problem:
Using radeon driver for an ATI Radeon 9200SE, ctrl+alt+plus ctrl+alt+minus keys
do nothing.  xvidtune -prev and xvidtune -next do nothing.  Nothing in the log.
 Only "xrandr --output DVI-0 --mode ..." works, but it is slow.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati 6.7.196-1.fc8

How reproducible:
every time

Steps to Reproduce:
1.get into KDE
2.press ctrl+alt+plus or ctrl+alt+minus
3.OR  issue  "xvidtune -next" or "xvidtune -prev"
  
Actual results:
nothing happens

Expected results:
Switch screen to next/previos video mode.

Additional info:
This worked in Fedora 7.  Used same xorg.conf in both releases.  Also tried some
changes to xorg.conf, but no effect.
Comment 1 Douglas Wooster 2007-12-07 00:11:58 EST
Created attachment 280581 [details]
log from FC7, where X zoom keys and xvidtune work correctly

Here's a log from Fedora 7.  Everything works correctly here.  This was
xorg-x11-drv-ati 6.6.3-4.fc7 .
Comment 2 Douglas Wooster 2007-12-07 00:15:05 EST
Created attachment 280591 [details]
xorg.conf which worked on FC7

This xorg.conf worked fine on Fedora 7.  It is also the first xorg.conf which I
tried on Fedora 8.  It does not work on FC8.  In addition to zoom keys not
working, it produced a default max screen size of 2048x1200, whereas FC7
allowed 2048x1536.
Comment 3 Douglas Wooster 2007-12-07 00:17:38 EST
Created attachment 280601 [details]
latest FC8 xorg.conf

Modified the previous xorg.conf to look like this, to try to resolve problems. 
This fixed the part where it thought 2048x1200 was largest possible size.  Does
not have any effect on the zoom problem, however.
Comment 4 Douglas Wooster 2007-12-07 00:20:07 EST
Created attachment 280611 [details]
FC8 log, after trying zoom keys, xvidtune, and finally xrandr

xrandr --output DVI-0 --mode 1280x1024
worked.  Neither zoom keys nor xvidtune worked.
Comment 5 Douglas Wooster 2007-12-07 00:36:31 EST
Hardware:
IBM 6652-U3N 21" CRT
ATI Radeon 9200SE
Athlon/XP 2600+
VIA KT400

Kernel 2.6.23.1-49.fc8
GNOME 2.20.1 and KDE 3.5.8 (fails on both)
Comment 6 Adam Sulmicki 2008-04-19 12:27:52 EDT
I have the same problem with fedora 7. Did it break on fedora 7 lately?

* Alt-Ctrl-+/0 does not work.
* xvidtune -next does not work.
* xrandr -s 640x480 does work.

I have needed stuff in /etc/X11/xorg.conf : 

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

This is troublesome since some games use xvidtune method rather than xrandr method.

gfx card : Display controller: ATI Technologies Inc RV350 AR [Radeon 9600]
Comment 7 Bug Zapper 2008-11-26 03:52:47 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-01-09 02:30:45 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.